Bug 1238434 - /usr/share/ipxe/undionly.kpxe’: No such file or directory
Summary: /usr/share/ipxe/undionly.kpxe’: No such file or directory
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: Director
Assignee: Mike Burns
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-01 20:36 UTC by bigswitch
Modified: 2015-08-05 13:58 UTC (History)
7 users (show)

Fixed In Version: ipxe-20130517-6.gitc4bce43.el7
Doc Type: Bug Fix
Doc Text:
The ipxe-bootimgs package was unavailable in the default Red Hat Enterprise Linux repository. It was only available in the Red Hat Enterprise Linux - Optional repository. This caused deployments without the Optional channel to fail. This fix adds this package to the director channel. Deployments now work without the Optional channel enabled.
Clone Of:
Environment:
Last Closed: 2015-08-05 13:58:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
~/.instack/install-undercloud.log (6.97 KB, text/plain)
2015-07-01 21:47 UTC, bigswitch
no flags Details
~/.instack/install-undercloud.log (682.41 KB, text/plain)
2015-07-01 21:51 UTC, bigswitch
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description bigswitch 2015-07-01 20:36:20 UTC
Description of problem:
I'm using RHOSP7 beta2 and following doc and release notes to install undercloud
ftp://partners.redhat.com/9be6fa88fb85ba9c78c8f3fe47e038c5/OpenStack/Documents/director-01jul-html/installation/installing.html
ftp://partners.redhat.com/9be6fa88fb85ba9c78c8f3fe47e038c5/OpenStack/Documents/osp-7-beta-issues3.txt

The problem I ran into is as following
[stack@manager ~]$ openstack undercloud install
...
dib-run-parts Wed Jul 1 12:58:19 PDT 2015 86-selinux completed
+ for target in '$targets'
+ output 'Running /tmp/tmpgpjAeU/post-install.d/88-setup-ipxe'
++ date
+ echo dib-run-parts Wed Jul 1 12:58:19 PDT 2015 Running /tmp/tmpgpjAeU/post-install.d/88-setup-ipxe
dib-run-parts Wed Jul 1 12:58:19 PDT 2015 Running /tmp/tmpgpjAeU/post-install.d/88-setup-ipxe
+ target_tag=88-setup-ipxe
+ date +%s.%N
+ /tmp/tmpgpjAeU/post-install.d/88-setup-ipxe
+ set -o pipefail
+ mkdir -p /httpboot
+ chown ironic:ironic -R /httpboot
+ install -o ironic -g ironic -m 744 /usr/share/ipxe/undionly.kpxe /tftpboot/undionly.kpxe
install: cannot stat ‘/usr/share/ipxe/undionly.kpxe’: No such file or directory
INFO: 2015-07-01 12:58:19,798 -- ############### End stdout/stderr logging ###############
ERROR: 2015-07-01 12:58:19,799 --     Hook FAILED.
ERROR: 2015-07-01 12:58:19,799 -- Failed running command ['dib-run-parts', u'/tmp/tmpgpjAeU/post-install.d']
  File "/usr/lib/python2.7/site-packages/instack/main.py", line 163, in main
    em.run()
  File "/usr/lib/python2.7/site-packages/instack/runner.py", line 79, in run
    self.run_hook(hook)
  File "/usr/lib/python2.7/site-packages/instack/runner.py", line 174, in run_hook
    raise Exception("Failed running command %s" % command)
ERROR: 2015-07-01 12:58:19,799 -- None
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 499, in install
    _run_instack(instack_env)
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 436, in _run_instack
    _run_live_command(args, instack_env, 'instack')
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 279, in _run_live_command
    raise RuntimeError('%s failed. See log for details.', name)
RuntimeError: ('%s failed. See log for details.', 'instack')
ERROR: openstack Command 'instack-install-undercloud' returned non-zero exit status 1


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 James Slagle 2015-07-01 21:24:01 UTC
/usr/share/ipxe/undionly.kpxe ought to be installed when ipxe-bootimgs is installed.

That package probably didn't install, but please confirm by running:
rpm -q ipxe-bootimgs

Please also attach ~/.instack/install-undercloud.log (from the home dir of the user that ran "openstack undercloud install", looks like stack in this case)

Comment 4 James Slagle 2015-07-01 21:25:43 UTC
can you also check if ipxe-bootimgs is available from any enabled repos on the undercloud?

yum list --show-duplicates ipxe-bootimgs

Comment 5 bigswitch 2015-07-01 21:46:07 UTC
[stack@manager ~]$ rpm -q ipxe-bootimgs
package ipxe-bootimgs is not installed

Comment 6 bigswitch 2015-07-01 21:47:01 UTC
Created attachment 1045257 [details]
~/.instack/install-undercloud.log

Comment 7 bigswitch 2015-07-01 21:51:21 UTC
Created attachment 1045258 [details]
~/.instack/install-undercloud.log

Comment 8 bigswitch 2015-07-01 21:52:41 UTC
(In reply to bigswitch from comment #6)
> Created attachment 1045257 [details]
> ~/.instack/install-undercloud.log

This attachment is wrong. Don't bother to look at it. Sorry

Comment 9 bigswitch 2015-07-01 21:53:06 UTC
(In reply to bigswitch from comment #6)
> Created attachment 1045257 [details]
> ~/.instack/install-undercloud.log

This attachment is wrong. Don't bother to look at it. Sorry

Comment 10 bigswitch 2015-07-01 21:54:17 UTC
(In reply to bigswitch from comment #7)
> Created attachment 1045258 [details]
> ~/.instack/install-undercloud.log

This is the right install-undercloud.log

Comment 11 bigswitch 2015-07-01 21:57:17 UTC
[stack@manager ~]$ yum list --show-duplicates ipxe-bootimgs
Loaded plugins: langpacks, product-id, subscription-manager
Repo rhel-ha-for-rhel-7-server-rpms forced skip_if_unavailable=True due to: /etc/pki/entitlement/7136784154980907288-key.pem
Repo rhel-7-server-rpms forced skip_if_unavailable=True due to: /etc/pki/entitlement/7136784154980907288-key.pem
RH7-RHOS-7.0                                                                                                                             469/469
RH7-RHOS-7.0-director                                                                                                                      53/53
Error: No matching Packages to list

Comment 12 James Slagle 2015-07-01 22:00:47 UTC
ok, looks like ipxe-bootimgs is in the rhel-7-server-optional-rpms repo so that needs to be enabled.

We will work on an update to the beta instructions to say that the optional repo is needed after all.

Comment 13 bigswitch 2015-07-01 22:08:23 UTC
Can I use following as a workaround?

# subscription-manager repos --enable rhel-7-server-optional-rpms

Comment 14 bigswitch 2015-07-01 22:08:39 UTC
Can I use following as a workaround?

# subscription-manager repos --enable rhel-7-server-optional-rpms

Comment 15 Mike Burns 2015-07-01 22:11:02 UTC
Yes, that will work for a workaround.  For GA, we'll make sure that's in a regular repo.

Thanks for the bug report.

Comment 16 Mike Burns 2015-07-01 22:14:02 UTC
If you do see anything else coming out of optional other than this single package, please let us know.

Thanks!

Comment 20 Udi 2015-07-06 15:27:22 UTC
Mike, should this package be found on so many sources or just 1:

]$ sudo yum list --show-duplicates ipxe-bootimgs
Loaded plugins: langpacks, product-id, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Installed Packages
ipxe-bootimgs.noarch   20130517-6.gitc4bce43.el7  @rhel-optional             
Available Packages
ipxe-bootimgs.noarch   20130517-6.gitc4bce43.el7  rhel-optional              
ipxe-bootimgs.noarch   20130517-6.gitc4bce43.el7  rhelosp-7.0-director-puddle
ipxe-bootimgs.noarch   20130517-6.gitc4bce43.el7  rhelosp-rhel-7-server-opt  
ipxe-bootimgs.noarch   20130517-6.gitc4bce43.el7  rhelosp-rhel-7-z

Comment 21 Udi 2015-07-06 17:26:22 UTC
No errors in the install log any more, by the way.

Comment 22 Mike Burns 2015-07-07 12:06:16 UTC
(In reply to Udi from comment #20)
> Mike, should this package be found on so many sources or just 1:

In short, yes and no.  I'll explain each one below

> 
> ]$ sudo yum list --show-duplicates ipxe-bootimgs
> Loaded plugins: langpacks, product-id, subscription-manager
> This system is not registered to Red Hat Subscription Management. You can
> use subscription-manager to register.
> Installed Packages


> ipxe-bootimgs.noarch   20130517-6.gitc4bce43.el7  @rhel-optional             
> Available Packages
> ipxe-bootimgs.noarch   20130517-6.gitc4bce43.el7  rhel-optional              
These 2 are the same.  The package is expected to be there.  You shouldn't have rhel-optional enabled though.


> ipxe-bootimgs.noarch   20130517-6.gitc4bce43.el7  rhelosp-7.0-director-puddle

This is the one that verifies the bug ^^

> ipxe-bootimgs.noarch   20130517-6.gitc4bce43.el7  rhelosp-rhel-7-server-opt  

This shouldn't be enabled, but the package is expected to be there.

> ipxe-bootimgs.noarch   20130517-6.gitc4bce43.el7  rhelosp-rhel-7-z

This is why we didn't catch the bug before.  It *shouldn't* be in here, but it's a limitation of using internal repos rather than CDN.

Comment 24 errata-xmlrpc 2015-08-05 13:58:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.