Bug 1238532 - qemu needs a better warning when the qemu-ifup script is busy
Summary: qemu needs a better warning when the qemu-ifup script is busy
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: 7.3
Assignee: jason wang
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: RHV4.1PPC
TreeView+ depends on / blocked
 
Reported: 2015-07-02 05:41 UTC by Xiaoqing Wei
Modified: 2016-11-07 20:26 UTC (History)
12 users (show)

Fixed In Version: qemu-kvm-rhev-2.5.0-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-07 20:26:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Description Xiaoqing Wei 2015-07-02 05:41:32 UTC
Description of problem:

qemu needs a better warning when the qemu-ifup script is busy

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.3.0-2.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. enter python interactive interface and open qemu-ifup in "w" mode

In [4]: f = open("/etc/qemu-ifup", "w")
In [5]: print f
<open file '/etc/qemu-ifup', mode 'w' at 0x1d34db0>

2. now launching a qemu process with this script
qemu-kvm -monitor stdio -S -device virtio-net-pci,mac=9a:81:82:83:84:85,id=idR5RhhY,netdev=iduPtGrR  -netdev tap,id=iduPtGrR,vhost=on,script=/etc/qemu-ifup
/etc/qemu-ifup: could not launch network script
qemu-kvm: -netdev tap,id=iduPtGrR,vhost=on,script=/etc/qemu-ifup: Device 'tap' could not be initialized

3.

Actual results:
/etc/qemu-ifup: could not launch network script
qemu-kvm: -netdev tap,id=iduPtGrR,vhost=on,script=/etc/qemu-ifup: Device 'tap' could not be initialized


Expected results:
qemu should raise a more descriptive error

eg:
Text file busy: /etc/qemu-ifup


Additional info:

Comment 1 jason wang 2015-07-02 05:46:02 UTC
Change the priority to low, libvirt does not use ifup.

Comment 3 Xiaoqing Wei 2015-07-02 06:10:43 UTC
upstream qemu would be a bit more descriptive by giving an error number,
rather then just telling it failed.

./qemu-system-x86_64 -monitor stdio -S -device virtio-net-pci,mac=9a:81:82:83:84:85,id=idR5RhhY,netdev=iduPtGrR  -netdev tap,id=iduPtGrR,vhost=on,script=/etc/qemu-ifup
qemu-system-x86_64: -netdev tap,id=iduPtGrR,vhost=on,script=/etc/qemu-ifup: network script /etc/qemu-ifup failed with status 256

Comment 4 jason wang 2015-08-10 05:22:19 UTC
Low priority, postpone to 7.3.

Comment 8 weliao 2016-05-17 02:56:54 UTC
Reproduce this bug on qemu-kvm-rhev-2.3.0-31.el7.x86_64:
Steps to Reproduce:
1. enter python interactive interface and open qemu-ifup in "w" mode

In [4]: f = open("/etc/qemu-ifup", "w")
In [5]: print f
<open file '/etc/qemu-ifup', mode 'w' at 0x1d34db0>

2. now launching a qemu process with this script
qemu-kvm -monitor stdio -S -device virtio-net-pci,mac=9a:81:82:83:84:85,id=idR5RhhY,netdev=iduPtGrR  -netdev tap,id=iduPtGrR,vhost=on,script=/etc/qemu-ifup
/etc/qemu-ifup: could not launch network script
qemu-kvm: -netdev tap,id=iduPtGrR,vhost=on,script=/etc/qemu-ifup: Device 'tap' could not be initialized

------------------------------------------------------------------------------

Verify this bug on qemu-kvm-rhev-2.6.0-1.el7.x86_64:
The same test steps with above.
[root@dhcp-8-118 qemu260-1]# /usr/libexec/qemu-kvm -monitor stdio -S -device virtio-net-pci,mac=9a:81:82:83:84:85,id=idR5RhhY,netdev=iduPtGrR  -netdev tap,id=iduPtGrR,vhost=on,script=/etc/qemu-ifup
qemu-kvm: -netdev tap,id=iduPtGrR,vhost=on,script=/etc/qemu-ifup: network script /etc/qemu-ifup failed with status 256

More descriptive, So this bug fix well.

Comment 11 errata-xmlrpc 2016-11-07 20:26:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.