Bug 1238565 - nfs-utils should be installed as dependency of openshift-node rpm to allowe user add nfs volume
Summary: nfs-utils should be installed as dependency of openshift-node rpm to allowe u...
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.0.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Scott Dodson
QA Contact: Ma xiaoqiang
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-02 07:37 UTC by Johnny Liu
Modified: 2016-07-04 00:45 UTC (History)
7 users (show)

(edit)
If the nfs-utils package was not installed on a node host, when a user tried to add an NFS volume to an application, the mount operation would fail for the pod. This bug fix adds the nfs-utils package as a dependency for the openshift-node package so it is installed on all node hosts by default.
Clone Of:
(edit)
Last Closed: 2015-08-03 20:17:35 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1540 normal SHIPPED_LIVE Red Hat OpenShift Enterprise 3.0.1.0 bug fix and enhancement update 2015-08-04 00:17:18 UTC

Description Johnny Liu 2015-07-02 07:37:21 UTC
Description of problem:
When adding a nfs volume to app, due to nfs-utils is not installed on node, pod would be pending on deployment.


Version-Release number of selected component (if applicable):
openshift-3.0.0.1-1.git.4.eab4c86.el7ose.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install a minimal rhel7 server, on which nfs-utils would not be installed by default.
2. Set up ose-3.0
3. Try to add a NFS pvc to app

Actual results:
Pod creation would be pending there.
$ oc get po
NAME                                READY     REASON                                                                                                                                                                RESTARTS   AGE
openshift-php-upload-demo-4-79vet   0/1       Image: 172.30.222.140:5000/jialiu/openshift-php-upload-demo@sha256:bd7e8dfd4fcdeb3fc2e4f507a868fc1ac91974ee59558f259c75c09da0823fac is ready, container is creating   0          3m

Check log node log, fount the following message:
Jul 02 14:39:55 node2.cluster.local openshift-node[6634]: I0702 14:39:55.745369    6634 volumes.go:96] Used volume plugin "kubernetes.io/persistent-claim" for (volume.Spec)...EPersisten
Jul 02 14:39:55 node2.cluster.local openshift-node[6634]: I0702 14:39:55.745442    6634 nfs.go:168] NFS mount set up: /var/lib/openshift/openshift.local.volumes/pods/bfa4c6c5-2084-11...
Jul 02 14:39:55 node2.cluster.local openshift-node[6634]: E0702 14:39:55.749786    6634 mount_linux.go:103] Mount failed: exit status 32
Jul 02 14:39:55 node2.cluster.local openshift-node[6634]: Mounting arguments: 10.14.6.120:/opt/osev3-pv /var/lib/openshift/openshift.local.volumes/pods/bfa4c6c5-2084-11e5-a...ume nfs []
Jul 02 14:39:55 node2.cluster.local openshift-node[6634]: Output: mount: wrong fs type, bad option, bad superblock on 10.14.6.120:/opt/osev3-pv,
Jul 02 14:39:55 node2.cluster.local openshift-node[6634]: missing codepage or helper program, or other error
Jul 02 14:39:55 node2.cluster.local openshift-node[6634]: (for several filesystems (e.g. nfs, cifs) you might
Jul 02 14:39:55 node2.cluster.local openshift-node[6634]: need a /sbin/mount.<type> helper program)
Jul 02 14:39:55 node2.cluster.local openshift-node[6634]: In some cases useful info is found in syslog - try
Jul 02 14:39:55 node2.cluster.local openshift-node[6634]: dmesg | tail or so.
Jul 02 14:39:55 node2.cluster.local openshift-node[6634]: E0702 14:39:55.749926    6634 kubelet.go:1114] Unable to mount volumes for pod "openshift-php-upload-demo-4-79vet_...ipping pod



After manually install nfs-utils on node, re-run the above steps, it works.

Expected results:
nfs-utils should be installed as dependency of openshift-node rpm.

Additional info:

Comment 1 openshift-github-bot 2015-07-09 00:23:14 UTC
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/7a8966256430966a395cfb0437042fa72960e8c7
[RPMs] Add nfs-utils to openshift-node requires

Not all nodes will require NFS mounts but this adds only 4MiB on top of a
minimal RHEL7.1 installation.

Fixes Bug 1238565

Comment 3 Johnny Liu 2015-07-09 10:48:15 UTC
Verified this bug with openshift-node-3.0.1.0-0.git.167.74e2880.el7ose.x86_64, and PASS.

# rpm -q openshift-node
openshift-node-3.0.1.0-0.git.167.74e2880.el7ose.x86_64


# rpm -qR openshift-node|grep nfs
nfs-utils

Comment 5 errata-xmlrpc 2015-08-03 20:17:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1540


Note You need to log in before you can comment on or make changes to this bug.