Bug 1238698 - Unable to log out of plasma/kde session
Summary: Unable to log out of plasma/kde session
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-desktop
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: KDE SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-02 12:42 UTC by Roderick Johnstone
Modified: 2015-07-29 12:49 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-07-29 12:49:26 UTC


Attachments (Terms of Use)
backtrace of ksmserver process (7.53 KB, text/plain)
2015-07-21 09:18 UTC, Roderick Johnstone
no flags Details

Description Roderick Johnstone 2015-07-02 12:42:26 UTC
Description of problem:
Unable to log out of kde session using the log out option from the Start/Leave menu.

ksmserver process is often (maybe always) taking 100% cpu when you cannot log out.


Version-Release number of selected component (if applicable):
plasma-desktop-5.3.1-6.fc22.x86_64

How reproducible:
Sometimes

Steps to Reproduce:
1. Choose Start/Leave/ log out
2.
3.

Actual results:
Nothing happens.

Expected results:
Session is logged out.

Additional info:

Comment 1 Rex Dieter 2015-07-02 13:04:00 UTC
If you can get a backtrace of the hung ksmserver process, that would help diagnose things.

Comment 2 Roderick Johnstone 2015-07-02 15:11:42 UTC
Rex

Will do so when I can catch a hung ksmserver.

Can you give instructions please if you need more than:
gdb -p <pid-of-ksmserver>
backtrace

Also, do I need debuginfo packages installed? If so, which ones?

Is a strace of the ksmserver process going to be helpful as well?

Thanks

Roderick

Comment 3 Rex Dieter 2015-07-02 15:13:37 UTC
you'll need to run gdb as root, and ideally install some debuginfo, but that's the gist.


debuginfo-install plasma-workspace

Comment 4 Roderick Johnstone 2015-07-20 11:17:03 UTC
I'm still waiting to encounter this on a system that I installed the debuginfo packages on. I have seen the issue a couple of times since the original report but not for about a couple of weeks now.

Comment 5 Roderick Johnstone 2015-07-21 09:18:07 UTC
Created attachment 1054247 [details]
backtrace of ksmserver process

Finally managed to capture a backtrace of the 100% cpu ksmserver process, attached.

Comment 6 Rex Dieter 2015-07-29 12:49:26 UTC
Looks like it's getting hung up in nvidia's libGL somewhere, I'd suggest you notify nvidia.



#0  0x00007f58278a0e25 in _nv014tls ()
    at /usr/lib64/nvidia/tls/libnvidia-tls.so.346.72
#1  0x00007f582ae90406 in  () at /usr/lib64/nvidia/libGL.so.1
#2  0x00007f582ae90747 in  () at /usr/lib64/nvidia/libGL.so.1
#3  0x00007f582ae36424 in  () at /usr/lib64/nvidia/libGL.so.1
#4  0x00007f582ae6274b in  () at /usr/lib64/nvidia/libGL.so.1
#5  0x00007f582ae65aa8 in  () at /usr/lib64/nvidia/libGL.so.1
#6  0x00007f582ae5b7f3 in glXCreateContextAttribsARB ()
    at /usr/lib64/nvidia/libGL.so.1
#7  0x00007f5810106e64 in QGLXContext::init(QXcbScreen*, QPlatformOpenGLContext*) (this=0x2618fb0, screen=0x23eda00, share=<optimized out>) at qglxintegration.cpp:264
#8  0x00007f58100df3ab in QXcbIntegration::createPlatformOpenGLContext(QOpenGLContext*) const (this=<optimized out>, context=0x7ffe8d547a50) at qxcbintegration.cpp:254
#9  0x00007f582e0314bb in QOpenGLContext::create() (this=this@entry=0x7ffe8d547a50)
    at kernel/qopenglcontext.cpp:597
#10 0x00007f58101074ea in QGLXContext::queryDummyContext() ()
    at qglxintegration.cpp:657
#11 0x00007f5810107691 in QGLXContext::supportsThreading() ()
    at qglxintegration.cpp:688
#12 0x00007f5812a81e8b in QSGRenderLoop::instance() ()
    at /usr/src/debug/qtdeclarative-opensource-src-5.4.2/src/quick/scenegraph/qsgrenderloop.cpp:170


Note You need to log in before you can comment on or make changes to this bug.