Bug 1238706 - snapd/quota/nfs daemon's runs on the node, even after that node was detached from trusted storage pool
Summary: snapd/quota/nfs daemon's runs on the node, even after that node was detached ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: 3.7.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Gaurav Kumar Garg
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On: 1238070
Blocks: 1255386
TreeView+ depends on / blocked
 
Reported: 2015-07-02 12:52 UTC by Gaurav Kumar Garg
Modified: 2016-06-05 23:38 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Clone Of: 1238070
: 1255386 (view as bug list)
Environment:
Last Closed: 2015-09-09 09:38:06 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-07-02 12:57:59 UTC
REVIEW: http://review.gluster.org/11509 (glusterd: stop all the daemons services on peer detach) posted (#1) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

Comment 2 Anand Avati 2015-07-03 06:45:45 UTC
REVIEW: http://review.gluster.org/11509 (glusterd: stop all the daemons services on peer detach) posted (#2) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

Comment 3 Anand Avati 2015-08-20 12:33:57 UTC
REVIEW: http://review.gluster.org/11509 (glusterd: stop all the daemons services on peer detach) posted (#3) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 4 Avra Sengupta 2015-08-20 12:57:38 UTC
The above patch is for master branch, and this bug is for release 3.7 branch. The fix for release 3.7 branch can be found at http://review.gluster.org/#/c/11971/

Comment 5 Anand Avati 2015-08-21 13:37:38 UTC
REVIEW: http://review.gluster.org/11971 (glusterd: stop all the daemons services on peer detach) posted (#2) for review on release-3.7 by Gaurav Kumar Garg (ggarg@redhat.com)

Comment 6 Anand Avati 2015-08-25 06:14:45 UTC
REVIEW: http://review.gluster.org/11971 (glusterd: stop all the daemons services on peer detach) posted (#3) for review on release-3.7 by Gaurav Kumar Garg (ggarg@redhat.com)

Comment 7 Anand Avati 2015-08-26 11:58:11 UTC
COMMIT: http://review.gluster.org/11971 committed in release-3.7 by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit 9d71c362b11544494b3fe68477cc47abe3bb2cde
Author: Gaurav Kumar Garg <garg.gaurav52@gmail.com>
Date:   Fri Aug 21 19:03:03 2015 +0530

    glusterd: stop all the daemons services on peer detach
    
    Backport of:  http://review.gluster.org/#/c/11509/
    
    Currently glusterd is not stopping all the deamon service on peer detach
    
    With this fix it will do peer detach cleanup properlly and will stop all
    the daemon which was running before peer detach on the node.
    
    Change-Id: Ifed403ed09187e84f2a60bf63135156ad1f15775
    BUG: 1238706
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    Reviewed-on: http://review.gluster.org/11971
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 8 Kaushal 2015-09-09 09:38:06 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.