Bug 123871 - Postgresql upgrade leaves old database format with no warning
Postgresql upgrade leaves old database format with no warning
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: postgresql (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-21 01:56 EDT by James
Modified: 2013-07-02 23:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-21 12:40:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James 2004-05-21 01:56:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux 2.6.5-1.358; X11; i686; , en_AU, en_AU.UTF-8, en) (KHTML, like Gecko)

Description of problem:
Upgrading postgresql requires that the database initially by dumped.  When I upgraded from FC1 to FC2, it upgraded postgres, but no warning was given to me about this.  This means I now need to install postgres 7.3 to dump my database, and then reinstall 7.4.2, and import it.  I think there should at least be some warning when postgres, and other applications that may cause similar problems, are going to be upgraded, because when you're upgrading distros, you don't always expect that the version will change.

Version-Release number of selected component (if applicable):
postgresql-7.4.2-1

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora core 1 and set up a postgres database
2. Upgrade to Fedora core 2

    

Actual Results:  Database is unusable

Expected Results:  Either database should have been dumped, or user warned that database would be unusable.

Additional info:
Comment 1 Tom Lane 2004-05-21 12:40:15 EDT
There isn't any really decent way to deal with this in the current RPM
structure.  A warning is not possible because RPM installation has to
be noninteractive, and an implicit upgrade doesn't seem very practical
either.

There's been some talk of changing where the RPM installs Postgres so
that things go into version-specific directories, thereby allowing
more than one major Postgres version to exist on your system
simultaneously.  Then you could install new version, dump and reload
data at your convenience, remove old version.  The various packagers
of Postgres are still working on that idea though.
Comment 2 Bill McGonigle 2009-04-21 01:31:52 EDT
I'm adding to this 5-year stale bug because in my experience this still bites more people than anything save random package conflicts on server upgrades (I'm cleaning up one now).

Just thinking out loud: what if there were an optional package that could be installed with a dependency on the current postgresql version that would run a pre-uninstall script to pg_dumpall as yum pulled it out for upgrade?  At least then the admin could just import the dump and be on his merry way, rather than stuck finding another machine or installing the old version from source.

I say that not having ever written an RPM anything like that...

Note You need to log in before you can comment on or make changes to this bug.