Bug 1238768 - Starred environments are NOT suggested for promotion
Summary: Starred environments are NOT suggested for promotion
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Christine Fouant
QA Contact: sthirugn@redhat.com
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-02 14:57 UTC by Fred van Zwieten
Modified: 2019-09-26 18:06 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:53:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (201.15 KB, image/png)
2015-07-02 14:57 UTC, Fred van Zwieten
no flags Details
Screenshot (99.76 KB, image/png)
2015-07-16 18:49 UTC, sthirugn@redhat.com
no flags Details
Environments w/stars - snap13 (162.33 KB, image/png)
2015-07-20 14:51 UTC, Christine Fouant
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 11076 None None None 2016-04-22 15:34:30 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Fred van Zwieten 2015-07-02 14:57:22 UTC
Created attachment 1045534 [details]
screenshot

Description of problem:
The promotion web page has the text "Starred environments are suggested for promotion" However, non of the environments have a star.

Version-Release number of selected component (if applicable):
6.1.0  Compose 20150625.2

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:
No starred envirnment

Expected results:
suggested environment is "starred"

Additional info:
see screenshot

Comment 1 RHEL Program Management 2015-07-02 15:13:51 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Christine Fouant 2015-07-09 19:03:51 UTC
Fixed by https://github.com/Katello/bastion/pull/64, waiting on Bastion gem version 1.0.2 to make it into production

Comment 4 Christine Fouant 2015-07-09 19:58:12 UTC
Created redmine issue http://projects.theforeman.org/issues/11076 from this bug

Comment 5 Christine Fouant 2015-07-09 20:40:45 UTC
(In reply to Christine Fouant from comment #3)
> Fixed by https://github.com/Katello/bastion/pull/64, waiting on Bastion gem
> version 1.0.2 to make it into production

Incorrect: created a new pull request to fix broken communication between katello and bastion. https://github.com/Katello/katello/pull/5349

Comment 6 Bryan Kearney 2015-07-10 02:04:53 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/11076 has been closed
-------------
Christine Fouant
Applied in changeset commit:katello|560a9991fb6b1cba305e2a81c5281a2503deae0f.

Comment 9 sthirugn@redhat.com 2015-07-16 18:49:14 UTC
Failed in Sat 6.1 GA Snap 13.  I dont see stars in the lifecycle-environments yet.

Comment 10 sthirugn@redhat.com 2015-07-16 18:49:34 UTC
Created attachment 1052822 [details]
Screenshot

Comment 11 Christine Fouant 2015-07-20 14:50:46 UTC
(In reply to sthirugn from comment #9)
> Failed in Sat 6.1 GA Snap 13.  I dont see stars in the
> lifecycle-environments yet.

Can you try again? I just did a fresh install of Snap 13, and it works for me.

Comment 12 Christine Fouant 2015-07-20 14:51:28 UTC
Created attachment 1053955 [details]
Environments w/stars - snap13

Comment 13 Bryan Kearney 2015-07-20 15:59:11 UTC
moving back to

Comment 14 sthirugn@redhat.com 2015-07-22 19:39:06 UTC
Verified in Sat 6.1 GA Snap 14.

Note: When I tested this in Snap 14, it looked like it didn't work first but it started working suddenly.  I tried multiple times after that and it worked great.  I will reopen this if I see any scenario in which this doesn't work.

Comment 15 Bryan Kearney 2015-08-12 16:02:50 UTC
This bug was fixed in Satellite 6.1.1 which was delivered on 12 August, 2015.

Comment 16 Fred van Zwieten 2015-08-14 14:13:20 UTC
There are still situations where the asterix is not shown. This is seen on the 6.1 GA.

Comment 20 sthirugn@redhat.com 2016-03-16 19:51:22 UTC
@Fred, Is there a specific scenario which fails here? I am not able to reproduce this in latest 6.2 build.  Please let me know.

Comment 21 sthirugn@redhat.com 2016-03-24 19:00:47 UTC
Verified in Satellite 6.2-beta-snap-5.1.  Screencast attached.  Please reopen with a screencast or a reproducer if this happens again.

Comment 24 Fred van Zwieten 2016-04-04 11:03:23 UTC
None other than in the supplied screenshot.

Comment 25 sthirugn@redhat.com 2016-04-04 13:05:33 UTC
Thank you Fred.  I am going to leave this bug as VERIFIED for now.  If I come across this error scenario again, I will reopen.

Comment 27 errata-xmlrpc 2016-07-27 08:53:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.