This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 123897 - Wheel not working with Intellimouse PS/2 (+synaptics driver)
Wheel not working with Intellimouse PS/2 (+synaptics driver)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-21 10:02 EDT by Tmp user
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-07 04:17:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tmp user 2004-05-21 10:02:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0; H-551M)

Description of problem:
After updgrading from FC1 to FC2, the wheel stopped working. The 
mouse is an "Intellimouse" manufactured by Dell under licence of 
Kro$oft.

/usr/bin/mouseconfig : I selected "Generic - Wheelmouse PS/2"

XF86Config :

	Option		"Protocol"		"IMPS/2"
	Option		"ZAxisMapping"		"4 5"

hwbrowser reports :

ImPS2 Generic Wheelmouse
Synaptics Touchpad

This is a HP XE3 laptop with a touch pad. 

I no one else reported this problem, it could be a conflict with the 
synaptics driver.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Upgrade FC1 --> FC2 on a laptop with Synaptic touchpad AND a PS/2 
intellimouse
2. Try the wheel
3.
    

Actual Results:  Wheel Not working (buttons and movement OK)

Expected Results:  Wheel to scroll up/down in X applications

Additional info:

Tested under gnome envt.
Comment 1 Robert G. Werner 2004-05-21 19:21:47 EDT
I'm seeing a behavior with My MS Intelimouse Optical USB and PS/2
compatable where X is detecting several buton presses when I scroll
the wheel up:
xev -display :0.0
ButtonPress event, serial 27, synthetic NO, window 0x2c00001,
    root 0x48, subw 0x0, time 17753356, (53,86), root:(804,468),
    state 0x0, button 2, same_screen YES

ButtonPress event, serial 27, synthetic NO, window 0x2c00001,
    root 0x48, subw 0x0, time 17753356, (53,86), root:(804,468),
    state 0x200, button 3, same_screen YES

ButtonPress event, serial 27, synthetic NO, window 0x2c00001,
    root 0x48, subw 0x0, time 17753356, (53,86), root:(804,468),
    state 0x600, button 4, same_screen YES

ButtonRelease event, serial 27, synthetic NO, window 0x2c00001,
    root 0x48, subw 0x0, time 17753356, (53,86), root:(804,468),
    state 0xe00, button 4, same_screen YES

All these button press events are generated when I roll the mouse
wheel up one notch.
Scrolling down works fine.
Comment 2 marc frei 2004-05-23 11:52:07 EDT
Same problem here than originally described. 

XF86Config-4 :

Section "InputDevice"
  Identifier  "Mouse0"
  Driver      "mouse"
  Option      "Protocol" "IMPS/2"
  Option      "Device" "/dev/mouse"
  Option      "Emulate3Buttons" "no"
  Option      "ZAxisMapping" "4 5"
EndSection

when using "xev", the up/down with the wheel is NOT recognized has an
X event.
Comment 3 marc frei 2004-05-24 18:31:12 EDT
OK... I found out why I had this problem, I think

Looking around, I saw that I didn't have an "xorg.conf" file.  

My FC1 didn't have "firstboot" installed. So, when I upgraded to FC2,
the firstboot program was not run afterward. "Fisrtboot" I guess run "
system-config-display".

So :
no "firstboot"  means no run of "system-config-display" means no
xorg.conf..... THEN MEANS lots of mouse/keyboard problems....

This should be improved/fixed in future release.

At least, now it works after running manually "system-config-display".
Comment 4 Mick Canning 2004-05-26 12:11:02 EDT
I have the same problem as described in comment #1 above, I get
exactly the same events displayed for a single up scroll. I am running
a 2.6.6 kernel as I had problems getting the nvidia drivers to work
with 2.6.5.x

Comment 5 Mick Canning 2004-05-26 12:51:22 EDT
I have found a possible work around to the multiple events generated
when using the mouse wheel to scroll up, 
Added the following to the kernel options 
"psmouse.proto=ipms"
Modified Mouse section of xorg.conf to,
        Option      "Device" "/dev/psaux"
The mouse wheel now behaves as expected, again I am running a 2.6.6
kernel but hopefully this will help on 2.6.5 as well. 

Comment 6 Robert G. Werner 2004-05-26 20:43:25 EDT
Tried the workaround on 2.6.5 but it didn't work.  Couldn't open
/dev/psaux .  
psaux was linked to major and minor 10, 1

Comment 7 Mick Canning 2004-05-27 08:35:46 EDT
Sorry the /dev/psaux is a red herring, I have modified
/etc/X11/xorg.conf to use the default /dev/input/mice for the mouse
device and the workaround is still good.

Comment 8 Robert G. Werner 2004-05-27 19:40:26 EDT
Thanks for the update.  Works for me to under 2.6.5 that comes on the
FC 2 disks.  Looks like this is the workaround.
Just for the record the kernel option is:
psmouse.proto = imps

Looks like this is the fix for lots of mouse problems.  I've seen this
kernel option suggested in several bugs.
Comment 9 Mike A. Harris 2004-05-28 04:06:20 EDT
The 2.6.x kernel does not have a psaux device, so you can not
configure /dev/psaux as a valid device.  Using /dev/psaux will result
only with error messages and unworking input devices, since it
does not exist.

/dev/input/mice is used in the 2.6.x kernel as a conglomerated
device providing events from all pointing devices.

/dev/input/mouseN can be used instead if you wish to use individual
devices.

I believe the problem reported in this bug report is not a bug, but
just a misconfiguration of the particular devices, or a lack of
support to do what you want with the kernel driver being used.  You
may wish instead to use the 3rd party open source "synaptics" driver,
however I'm not sure if it is possible to configure everything the
way you would like to.  You might want to ask on a public mailing
list first if what you'd like is actually possible with 2.6.x and
X.

Hope this helps.

Comment 10 Ray 2004-06-16 09:00:47 EDT
Where exactly do you add "psmouse.proto = imps" ? Please give the path
and file names. I couldnot find the Kernel Options in XF86Config file.
Comment 11 Mick Canning 2004-06-16 09:09:10 EDT
Modify your boot loader configuration file, for  GRUB modify
/boot/grub/grub.conf and append the option to the 'kernel' line. 
Comment 12 Mike A. Harris 2004-07-07 04:17:17 EDT
I'm going to close this "WORKSFORME" for now, but if the problem
still exists with the latest FC2 kernel installed, and all FC2
updates, with the special kernel commandline option removed, I
recomment doing:

rm -f /etc/X11/{XF86Config*,xorg.conf}

then running:

system-config-display

This will produce a new config file which will be free of any
possible defects that might occur when upgrading from FC1 to FC2.

If the problem persists in this setup, feel free to reopen the
report for another review.  Be sure to attach your X server config
file (xorg.conf), the server log file, and /var/log/messages to
the report uncompressed using the link below.


Note You need to log in before you can comment on or make changes to this bug.