Bug 1238990 (CVE-2015-3279) - CVE-2015-3279 cups-filters: texttopdf integer overflow
Summary: CVE-2015-3279 cups-filters: texttopdf integer overflow
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2015-3279
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20150702,repor...
Depends On: 1241242
Blocks: 1210268 1235386
TreeView+ depends on / blocked
 
Reported: 2015-07-03 08:28 UTC by Stefan Cornelius
Modified: 2019-06-08 20:39 UTC (History)
5 users (show)

Fixed In Version: cups-filters 1.0.71
Doc Type: Bug Fix
Doc Text:
An integer overflow flaw, leading to a heap-based buffer overflow, was discovered in the way the texttopdf utility of cups-filter processed print jobs with a specially crafted line size. An attacker able to submit print jobs could use this flaw to crash texttopdf or, possibly, execute arbitrary code with the privileges of the "lp" user.
Clone Of:
Environment:
Last Closed: 2015-11-20 05:05:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2015:2360 normal SHIPPED_LIVE Moderate: cups-filters security, bug fix, and enhancement update 2015-11-19 10:41:12 UTC

Description Stefan Cornelius 2015-07-03 08:28:41 UTC
An integer overflow flaw leading to a heap-based buffer overflow was
discovered in the way the texttopdf utility of cups-filter processed
print jobs with a specially crafted line size. An attacker being able
to submit print jobs could exploit this flaw to crash texttopdf or,
possibly, execute arbitrary code with the privileges of the 'lp' user.

Patch:
http://bzr.linuxfoundation.org/loggerhead/openprinting/cups-filters/revision/7365

Comment 1 Jiri Popelka 2015-07-03 11:39:26 UTC
Comment in
http://bzr.linuxfoundation.org/loggerhead/openprinting/cups-filters/revision/7365
claims it's CVE-2015-3259 (not 3279).

Comment 2 Tim Waugh 2015-07-03 14:05:47 UTC
That was my mistake. The correct name is CVE-2015-3279.

Comment 7 errata-xmlrpc 2015-11-19 12:08:25 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2015:2360 https://rhn.redhat.com/errata/RHSA-2015-2360.html


Note You need to log in before you can comment on or make changes to this bug.