Bug 123903 - Gateway 450 series laptop: Kernel Panic: Attempted to kill init
Gateway 450 series laptop: Kernel Panic: Attempted to kill init
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-21 11:03 EDT by Louis Lerman
Modified: 2015-01-04 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 01:51:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Louis Lerman 2004-05-21 11:03:30 EDT
Description of problem:
When attempting to install Fedora Core 2, the installation media 
boots, and upon hitting <enter> to continue the installation fails. 
The message "<0>Kernel panic: Attempted to kill init!" appears on the 
screen and the installation ends. The installation never makes it 
into graphical or text mode (I have tried both).

Version-Release number of selected component (if applicable):
Fedora Core 2

How reproducible:
Insert Fedora Core 2 Disk 1 into the drive and boot as doing a new 
installation. When the media boots press <enter> to enter graphical 
mode. Some text will scroll and then will cease with the 
message "Kernel panic: Attempted to kill init!".

Steps to Reproduce:
1. Insert Fedora Core 2 Disk 1
2. Boot system
3. Press <enter> to enter graphical mode, or type "linux text" and 
press <enter> to enter text mode
  
Actual results:
Installation fails

Expected results:
Installation should begin (in either graphical or text mode)

Additional info:
I am using a Gateway 450 series laptop, with; Pentium-4 M 1.4 GHz, 
1GB RAM, DVD/CDRW, ATI Mobility Radeon 9000 64MB. I have already set 
it up as a dual-boot system with Windows XP Pro and Red Hat 9.0 and 
am trying to replace the Red Hat 9.0 with Fedora Core 2.
Comment 1 Louis Lerman 2004-05-21 11:04:44 EDT
I forgot to mention, I have downloaded the Fedora Core 2 installation 
media twice from BitTorrent and have even downloaded just Disk 1 a 
third time. I have reburned the media and it still does not work.
Comment 2 Alan Cox 2004-05-21 18:39:43 EDT
Does the option "acpi=off" make it boot ?
Comment 3 David Bloomfield 2004-05-24 13:31:30 EDT
I have the same problem on my Dell GX260 desktop. I tried the 
acpi=off switch but it made no difference. Are there any other 
options I could try?

I downloaded the iso images from ftp.mirror.ac.uk . Using the same cd 
I've managed to install FC2 fine on a Dell Optiplex GX110 and it 
boots into the installer ok on a Dell Latitude D600, so it's not a 
problem with the install media.
Comment 4 Arjan van de Ven 2004-05-29 04:21:38 EDT
Is there anything useful just before the "attempting to kill init"?
Comment 5 David Bloomfield 2004-05-31 06:40:54 EDT
I've resolved my issue by removing the Nvidia Riva TNT2 video card 
from the gx260, it boots ok into the installer now, looks there's an 
incompatibility issue there (worked fine in FC1). Using the onboard 
intel chipset for graphics now. Louis' issue may be something 
different.
Comment 6 masaharu.akei@pep.ne.jp 2004-06-01 11:08:40 EDT
I have gotten the same result.
My PC is Panasonic Let's note CF-R3(note PC):
CPU: Pentium M 1.1GHz,
Memory:  256MB RAM
Gaphic: Intel(R) 82852/82855 GM/GME Graphics Controller
         1024 x 768 x 60Hz
I have used a dual-boot system with Windows XP Pro and FC1 and 
I am trying to replace FC1 to FC2.

Message during the instlation...
Code: 89 68 10 89 f8 e8 85 e1 00 00 b8 37 00 00 00 e8 96 e3 00 00
 <0>Kernel panic: Attempted to kill init!
Comment 7 Louis Lerman 2004-06-02 15:34:11 EDT
I got my FC2 to install using the "acpi=off" as described above. I 
did an UPGRADE install from RH9.0, but am going to try to do a 
clean/full install soon. As for "any useful information before the 
attempting to kill init," I just got the same message that Masaharu 
got above - just a code and then the "Kernel Panic" message.  
Comment 8 Paul Steckler 2004-06-06 11:55:52 EDT
I have a Gateway 450XL Centrino laptop.

I can confirm the kernel panic that occurs when 
booting from the 1st FC 2 CD.  The acpi=off
option allows the installation to proceed 
normally.

-- Paul Steckler
Comment 9 MadMike 2004-07-10 11:09:26 EDT
I have the same problem on laptop Asus M5200N (Centrino technology).
With acpi=off it work normally.
Comment 10 Dave Jones 2005-04-16 01:51:50 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.