Bug 1239046 - targetcli: can't list information from IPv6 portal
Summary: targetcli: can't list information from IPv6 portal
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-configshell
Version: 7.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Andy Grover
QA Contact: Martin Hoyer
URL:
Whiteboard:
Depends On:
Blocks: 1313485 1295577
TreeView+ depends on / blocked
 
Reported: 2015-07-03 11:20 UTC by Bruno Goncalves
Modified: 2017-08-01 20:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 20:54:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2031 normal SHIPPED_LIVE targetcli, python-configshell, python-rtslib bug fix and enhancement update 2017-08-01 18:34:25 UTC

Description Bruno Goncalves 2015-07-03 11:20:18 UTC
Description of problem:
It is not possible to list information from IPv6 portal using command line.


Version-Release number of selected component (if applicable):
targetcli-2.1.fb37-3.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1.Create an iSCSI target portal
2.Try to display some information 
# targetcli /iscsi/<tgt_iqn>/tpg1/portals/[::0]:3260 info
#


Actual results:
Nothing seems to be executed

Expected results:
Portal information should have been shown

Additional info:
No command available to a portal actually works

Executing "cd [::0]:3260" from targetcli tool also does not work well. 
It opens an interactive tree where it is possible to select the portal.

Comment 7 Martin Hoyer 2017-04-28 08:51:54 UTC
Andy,
there are still some issues with IPv6 portal:

If we want to display info from tpg/ instead of showing the info about portal, it will change directory to portals/ instead
iscsi/iqn.20...4b5768f2/tpg1> portals/[::0]:3260 info
/iscsi/iqn.20.../tpg1/portals>

We can change directory to the [::0]:3260/ and display info correctly
/iscsi/iqn.20...ls/[::0]:3260> info
ip_address: [::0]
iser: False
offload: False
port: 3260

Cannot list info from shell
# targetcli /iscsi/iqn.2003-01.org.linux-iscsi.localhost.x8664:sn.ff864b5768f2/tpg1/portals/[::0]:3260 info

All of the above works well with IPv4.
Tested with:
targetcli-2.1.fb46-1.el7
python-configshell-1.1.fb23-1.el7
python-rtslib-2.1.fb63-1.el7

Comment 9 Martin Hoyer 2017-05-31 14:44:50 UTC
Tested with python-configshell-1.1.fb23-3.el7
Works as expected, no regression found.

Comment 10 errata-xmlrpc 2017-08-01 20:54:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2031


Note You need to log in before you can comment on or make changes to this bug.