Bug 123905 - Bad advanced search permenantly hides all messages
Bad advanced search permenantly hides all messages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-21 11:47 EDT by Sitsofe Wheeler
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 14:28:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sitsofe Wheeler 2004-05-21 11:47:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
If you create an advanced search with a bad expression, then click
clear, all the messages in the folder you are currently viewing will
be hidden with no way of showing them short of restarting evolution.

Version-Release number of selected component (if applicable):
evolution-1.4.6-2

How reproducible:
Always

Steps to Reproduce:
1. Start evolution
2. Select a victim mailbox which has messages within it
3. Go to Search -> Advanced
4. Change Subject to Expression and enter "a" in the textbox to the right.
5. Click OK (an error dialog will appear). Click Close.
6. Go Search -> Clear
    

Actual Results:  All messages disappear

Expected Results:  All messages to be displayed (since we have just
"cleared" the search)

Additional info:

The Advanced Search's Expression feature is completely inscrutable and
seemingly undocumented. I wound out working out its syntax by adding
other rules and analysing the error message.
Comment 1 Dave Malcolm 2004-09-22 14:28:10 EDT
I just tried to reproduce this in evolution-2.0.0; steps 1-6 work as
reported (with an inscrutable error dialog), but at no point do the
messages disappear.

So the permanent message loss part of the bug looks fixed in Rawhide;
the rest I'm unlikely to spend engineering time on right now;
resolving as fixed in RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.