Bug 1239089 - /etc/issue in Fedora server should contain cockpit URL
Summary: /etc/issue in Fedora server should contain cockpit URL
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-release
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stephen Gallagher
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1110763 (view as bug list)
Depends On: 1239090
Blocks: cockpit-F21-tracker 1108258 1123345 F23BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2015-07-03 13:07 UTC by Stef Walter
Modified: 2015-10-01 15:00 UTC (History)
11 users (show)

Fixed In Version: 23-0.17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-16 02:25:28 UTC


Attachments (Terms of Use)

Description Stef Walter 2015-07-03 13:07:45 UTC
The /etc/issue file in Fedora Server should contain the Cockpit URL. This makes it easy for people who use Fedora Server in a VM or a server to find the URL needed.

Comment 1 Stef Walter 2015-07-03 13:07:56 UTC
This is possible like this in /etc/issue

https://\4:9090

Comment 2 Stephen Gallagher 2015-07-09 17:56:07 UTC
Some concerns:
1) What happens if there are multiple IP addresses? Which one gets displayed on the screen?
2) What about systems for which IPv6 is the default? Or IPv4 is not configured at all?

Comment 3 Stef Walter 2015-07-10 05:54:53 UTC
Getty supports both \4 and \6. It uses the first address (as listed in ip addrs or ifconfig ... that is up, not loopback and running). But it can be told to print the first address from a specific interface.

However in my opinion, this is not about getting it perfect, but getting it to work in most cases. There's no possible way to be perfect here. For example in a multi-host case, it's impossible to know which network the person viewing the screen may be able to access the system on.

In most cases where this is useful, the system has not yet been configured and there is exactly one DHCP address that would be displayed.

Comment 4 Fedora Blocker Bugs Application 2015-07-28 13:10:39 UTC
Proposed as a Freeze Exception for 23-alpha by Fedora user sgallagh using the blocker tracking app because:

 We want to get this functionality into the Alpha release in order to maximize testing. It's highly useful to users of the Fedora Server Edition.

Comment 5 Stef Walter 2015-08-03 09:06:07 UTC
Stephen, are you familiar enough with fedora-release to make the changes there? I've taken a look and the spec file + git repo seem quite complex.

Comment 6 Stephen Gallagher 2015-08-03 12:08:58 UTC
(In reply to Stef Walter from comment #5)
> Stephen, are you familiar enough with fedora-release to make the changes
> there? I've taken a look and the spec file + git repo seem quite complex.

Yes, I've spent numerous hours in that spec file. I'll handle that, once BZ #1239090 lands.

Comment 7 Petr Schindler 2015-08-03 17:06:04 UTC
Discussed at today's blocker review meeting [1].

This bug was accepted as Alpha Freeze Exception - We would consider a fix for this during the freeze period for Alpha.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2015-08-03/

Comment 8 Stephen Gallagher 2015-08-24 13:59:24 UTC
Pull-request for Fedora 24 (Rawhide): https://pagure.io/fedora-release/pull-request/5

Pull-request for Fedora 23: https://pagure.io/fedora-release/pull-request/6

Comment 9 Fedora Update System 2015-09-08 12:57:02 UTC
fedora-release-23-0.16 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15348

Comment 10 Fedora Update System 2015-09-08 17:51:17 UTC
fedora-release-23-0.16 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update fedora-release'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15348

Comment 11 Fedora Update System 2015-09-08 19:34:08 UTC
fedora-release-23-0.17 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15348

Comment 12 Stephen Gallagher 2015-09-09 14:21:40 UTC
Removing AcceptedFreezeException. This should be re-evaluated by the blocker review process, since the previous Exception was only granted for Alpha.

Comment 13 Fedora Update System 2015-09-10 05:52:21 UTC
fedora-release-23-0.17 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update fedora-release'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15348

Comment 14 Adam Williamson 2015-09-10 19:34:33 UTC
Discussed at 2015-09-10 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-09-10/f23-blocker-review.2015-09-10-16.00.log.txt . Accepted as a freeze exception for the same reasoning we accepted it for Alpha - this is something visible that can't be fixed post-release, and the fix would be relatively safe.

Comment 15 Fedora Update System 2015-09-16 02:25:27 UTC
fedora-release-23-0.17 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Stef Walter 2015-09-30 20:12:34 UTC
*** Bug 1110763 has been marked as a duplicate of this bug. ***

Comment 17 Stef Walter 2015-10-01 15:00:02 UTC
*** Bug 1110763 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.