Bug 123911 - yum thinks that compat-db obsoletes db4
yum thinks that compat-db obsoletes db4
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-21 12:33 EDT by Pavel Roskin
Modified: 2014-01-21 17:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-09 22:10:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This patch fixes the problem (525 bytes, patch)
2004-05-22 00:52 EDT, Pavel Roskin
no flags Details | Diff

  None (edit)
Description Pavel Roskin 2004-05-21 12:33:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
When I run "yum upgrade" on a clean default workstation install of
Fedora Core 2, it wants to download compat-db-4.1.25-2.1.i386 (and
also compat-libstdc++-7.3-2.96.126.i386 as dependency).
Running "yum -d 10 upgrade" shows following lines:

versioned obsolete
db4, 2, 0, 4.2, None
None, None, None vs 0, 4.2, None = -1
compat-db obsoleting db4
versioned obsolete
db4-devel, 2, 0, 4.2, None
None, None, None vs 0, 4.2, None = -1
compat-db obsoleting db4-devel
versioned obsolete
db4-utils, 2, 0, 4.2, None
None, None, None vs 0, 4.2, None = -1
compat-db obsoleting db4-utils
[snip]
nulist = 904
uplist = 0
newlist = 904
obsoleting = 1
obsoleted = 3
userlist entry *
db4-utils matched in oulist
db4-utils obsoleted by compat-db
db4 matched in oulist
db4 obsoleted by compat-db
db4-devel matched in oulist
db4-devel obsoleted by compat-db

compat-db only obsoletes versions of db4 prior to 4.2.  From the spec
file of compat-db:

Obsoletes: db2, db2-devel, db2-utils
Obsoletes: db3, db3-devel, db3-utils
Obsoletes: db31, db32, db3x
Obsoletes: db4 < 4.2, db4-devel < 4.2, db4-utils < 4.2

I have db4-4.2.52-3.1 installed.  It should not be obsoleted by
compat-db.  In fact, running "rpm -U compat-db-4.1.25-2.1.i386.rpm"
(provived that compat-libstdc++-7.3-2.96.126 is installed) succeeds
without an attempt to uninstall db4.


Version-Release number of selected component (if applicable):
yum-2.0.7-1.1

How reproducible:
Always

Steps to Reproduce:
1. Run "yum upgrade"


Actual Results:  yum suggests installing compat-db


Expected Results:  yum should not suggest installing compat-db

Additional info:

Clean Fedora Core 2 install as Workstation, all defaults.
Comment 1 Pavel Roskin 2004-05-22 00:52:31 EDT
Created attachment 100445 [details]
This patch fixes the problem

yum requests the version for the package being installed, but it should be
using the name of the candidate for obsoleting.  In my case, compat-db
obsoletes db4 4.2 and older.  4.2 is compared to the version of compad-db
rather than db4.  Also, rpmNevral.evr() doesn't work for packages that are not
installed yet.
Comment 2 Jeff Johnson 2004-06-09 22:10:14 EDT
Patch looks plausible, handed off to skvidal.

Please reopen if the bug is not fixed in next release of yum
into fc3.
Comment 3 Seth Vidal 2004-06-23 01:34:51 EDT
nice catch. I've applied it to cvs. It'll come out in yum 2.0.8

Thanks
-sv

Note You need to log in before you can comment on or make changes to this bug.