Bug 123920 - sound volume reset to zero when you enter X
sound volume reset to zero when you enter X
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-21 14:33 EDT by Chuck Mead
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-11 17:35:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chuck Mead 2004-05-21 14:33:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.6)
Gecko/20040510

Description of problem:
I chose a component for this bug report that is probably not the
problem. The deal is that the component which fixes the problem is not
a selectable component of FC2. So... this bug is probably not related
to redhat-config-soundcard but alsa-utils-1.0.3-1 is not a selectable
component and neither is system-config-soundcard. I guess bugzilla is
a bit behind. 

Anyway here's the problem:

While in gnome I set all my sound volumes. I have to use alsamixer to
do it because the GUI tools do not seem to work. Then... if I log out
of X (no reboot... just logout and then log back in) my sound values
are back to zero again. Running alsactl restore fixes it so I know
that the /etc/asound.state file is being written correctly.

Version-Release number of selected component (if applicable):
system-config-soundcard-1.2.8-1

How reproducible:
Always

Steps to Reproduce:
1. Set sound volumes with alsamixer
2. Log out.
3. Log back in and I have to set the sound values again (alsactl restore)
    

Actual Results:  Exactly as I said... if I set the volume and then log
out the volume settings are back to zero again. Running "alsactl
restore" puts it back to where I had it before.

Expected Results:  I should not have to mess with sound once again I
set it up.

Additional info:

I don't know if it's relevant or not but while running the
gnome-cdplayer I tried to adjust the sound volume using the volume
applet on the toolbar... I adjust it up... and it adjusts itself right
back down again and I can watch it slide back down on it's own. Weird!
Comment 1 petrosyan 2004-05-22 00:50:39 EDT
I can also see how the volume level starts going down. Red Hat folks
probably added gravitational forces in their latest desktop. If I set
the volume level to maximum it stays there. However any other volume
level, and it starts slowly decreasing until it gets to zero.
Comment 2 Martin Rebane 2004-07-09 21:16:07 EDT
I have exactly the same problem as described in the original bug
report, the additional comment, that volume level slides down does not
apply though.

Additional information that may help: it's not fresh FC2 install, but
an upgrade from RH8 - RH9 - FC1 - FC2
Comment 3 Bastien Nocera 2004-09-13 21:34:58 EDT
This would be the mixer applet. Could you confirm that you have the
mixer applet in your panel?
Comment 4 Lars Damerow 2005-01-25 12:34:31 EST
I'm seeing the volume slider decrease on its own as stated in comment
#1. This is also on FC2. Was a solution for this problem found?
Comment 5 Bastien Nocera 2005-01-25 12:37:30 EST
It's a bug in the gnome-applets (the mixer in your panel). Are you
using it?
Comment 6 Lars Damerow 2005-01-25 17:18:42 EST
We have gnome-applets-2.6.0-5 installed. I'll upgrade to 2.6.2.1-1 to
see if that helps. Thanks!
Comment 7 Ray Strode [halfline] 2005-05-11 17:35:03 EDT
Hi,

This bug is being closed because it has been in the NEEDINFO state for a long
time now.  Feel free to reopen the bug report if the problem still happens for
you and you can provide any information that was requested.

Note You need to log in before you can comment on or make changes to this bug.