Bug 123923 - (FS AUTOFS)Badness in interruptible_sleep_on at kernel/sched.c:1927
(FS AUTOFS)Badness in interruptible_sleep_on at kernel/sched.c:1927
Status: CLOSED DUPLICATE of bug 118413
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey Moyer
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-21 14:56 EDT by Orion Poplawski
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2004-05-21 14:56:18 EDT
Description of problem:

I'm getting the following messages on two identical dual processor
opteron machines:
Call Trace:<ffffffff802d2699>{interruptible_sleep_on+114}
<ffffffff801b6f86>{avc_has_perm+70}
       <ffffffff80130c9a>{default_wake_function+0}
<ffffffffa00c887e>{:autofs4:autofs4_wait+501}
       <ffffffffa00c7669>{:autofs4:try_to_fill_dentry+76}
       <ffffffff801766b1>{do_lookup+102}
<ffffffff80176a52>{link_path_walk+894}
       <ffffffff80177409>{path_lookup+436}
<ffffffff80177590>{__user_walk+47}
       <ffffffff80172819>{vfs_stat+24} <ffffffff801231a2>{sys32_stat64+17}
       <ffffffff80111b31>{error_exit+0}
<ffffffff80122bd3>{cstar_do_call+27}

Badness in interruptible_sleep_on at kernel/sched.c:1927

Call Trace:<ffffffff802d2699>{interruptible_sleep_on+114}
<ffffffff80130c9a>{default_wake_function+0}
       <ffffffffa00c887e>{:autofs4:autofs4_wait+501}
<ffffffffa00c7669>{:autofs4:try_to_fill_dentry+76}
       <ffffffff80176482>{real_lookup+202}
<ffffffff8017669c>{do_lookup+81}
       <ffffffff80176a52>{link_path_walk+894}
<ffffffff80177409>{path_lookup+436}
       <ffffffff80177590>{__user_walk+47} <ffffffff80172819>{vfs_stat+24}
       <ffffffff801231a2>{sys32_stat64+17}
<ffffffff80111b31>{error_exit+0}
       <ffffffff80122bd3>{cstar_do_call+27}
Badness in interruptible_sleep_on at kernel/sched.c:1927

Call Trace:<ffffffff802d2699>{interruptible_sleep_on+114}
<ffffffff801b6f86>{avc_has_perm+70}
       <ffffffff80130c9a>{default_wake_function+0}
<ffffffffa00c887e>{:autofs4:autofs4_wait+501}
       <ffffffffa00c7669>{:autofs4:try_to_fill_dentry+76}
       <ffffffff801766b1>{do_lookup+102}
<ffffffff80176a52>{link_path_walk+894}
       <ffffffff80177409>{path_lookup+436}
<ffffffff80177590>{__user_walk+47}
       <ffffffff80172819>{vfs_stat+24} <ffffffff801231a2>{sys32_stat64+17}
       <ffffffff80111b31>{error_exit+0}
<ffffffff80122bd3>{cstar_do_call+27}


Version-Release number of selected component (if applicable):
kernel-smp-2.6.5-1.358


How reproducible:
Hard to trigger.  Might be related to having home directories NFS
automounted from a sever and having multiple logins happening quickly:

May 21 12:49:30 coop01 sshd(pam_unix)[26009]: session opened for user
orion by (uid=1744)
May 21 12:49:31 coop01 sshd(pam_unix)[26046]: session opened for user
orion by (uid=1744)
May 21 12:49:32 coop01 kernel: Badness in interruptible_sleep_on at
kernel/sched.c:1927


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

It doesn't appear to cause any problems, but kernel "Badness" is
worrisome!
Comment 1 Alan Cox 2004-05-21 18:35:46 EDT
The message is triggered when the kernel spots a potentially unsafe
use of interruptible_sleep_on. In most cases this causes no problems
and many such errors were in 2.4 and never noticed or triggered
problems for 99.99% of people. 2.6 now traps them so they get fixed.
Comment 2 Jeffrey Moyer 2004-05-21 19:00:00 EDT

*** This bug has been marked as a duplicate of 118413 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:03:25 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.