Bug 123925 - (PS2)ps/2 keyboard and mouse stop working
(PS2)ps/2 keyboard and mouse stop working
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-21 15:03 EDT by William Caban
Modified: 2015-01-04 17:06 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 01:47:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Caban 2004-05-21 15:03:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
This apply to DELL Precision 530 and MEDIO2900 Laptop

On DELL Precision 530 (dual capable but single processor)

At the first reboot after the installation once the kernel loads and
the graphical boot process start the ps/2 keyboard and mouse stop
working. If a USB keyboard is used the problem does not affect the USB
keyboard.
The kernel installed by anaconda was smp and every time I tried to
boot with the ps/2 keyboard and mouse both stop working. The problem
is not present if USB keyboard is used.

The problem completely disappear if the kernel-smp is replaced by the
regular kernel.

On the MEDION 2900 laptop the problem happen at the first screen of
the installation that ask for verify the media or not. If a USB
keyboard is used there is no problem with the installation.

On the MEDION laptop, after installed, the problem didn't occur. 

Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-2

How reproducible:
Always

Steps to Reproduce:
On the MEDION Laptop
1. insert the installation CD once the screen asking to verify the
media appear the keyboard and mouse stop working
2. plug an external USB keyboard and reboot and the installation
process can be completed without problems
On the DELL Precision 530 (dual capable but with one CPU) using ps/2
keyboard and mouse
1. do the first part of the installation until it ask for reboot
2. when the graphical boot is started the keyboard and mouse are
already freeze
3. boot the machine with a USB keyboard and replace the smp kernel
with the single processor kernel and the problem disappear.
    

Additional info:
Comment 1 Alan Cox 2004-05-21 18:33:21 EDT
Media verify occurs before X is started therefore moving this to kernel
Comment 2 Dong-Hee Kim 2004-05-28 15:27:21 EDT
I have suffered from the same problem
I cannot use PS2 keyboard and mouse with smp kernel.
My server consists of Intel 7501CW2 + dual Xeon.
Suprisingly, I fount that only keyboard works normally
when I pluged the keyborad to mouse port. But mouse still
doesn't work. And, when I boot with non-smp kernel, 
both of keyboard and mouse work fine.
Comment 3 Karl Auerbach 2004-06-04 21:15:21 EDT
I have what appears to be the same problem (including the 
mouse/keyboard swap), also on a dual Xeon Intel 7501 box (Supermicro 
6013P-i).  (Kernel 2.6.5-1.358smp)

Problem goes away when I boot non-SMP kernel.
Comment 4 Ruediger Fender 2004-06-19 10:50:02 EDT
The same problem occurs on an Acer 7600G (PIV 2,6 GHz HT) - no mouse
and keyboard function when booting the 2.6.6-1.435-smp kernel; no
problems with the 2.6.6-1.435 kernel.
Comment 5 Mike A. Harris 2004-07-06 03:04:22 EDT
Bug was reassigned to kernel, but not reassigned to kernel engineers.
Reassigning the human aspect also....  ;o)

Comment 6 Ruediger Fender 2004-08-05 13:17:49 EDT
With kernel 2.6.7-1.494.2.2smp the problem seems to be solved :-)
Comment 7 jie shen 2004-09-20 16:43:15 EDT
I tried kernel-smp-2.6.7-1.494.2.2.i686.rpm
and kernel-smp-2.6.8-1.521.i686.rpm. In both cases,
PS/2 keyboard would not work. But kernel-2.6.8-1.521.i686.rpm
works.
Comment 8 Mike A. Harris 2004-09-20 19:06:34 EDT
Both of the kernels are SMP that you indicate do not work, but the one
that you indicate works, is a UP kernel.  It seems as if this might
be an SMP kernel related issue perhaps.

Comment 9 Alan Cox 2004-09-21 05:48:46 EDT
The E750x one is SMP specific. Since Jie Shen doesn't give any
hardware info its hard to speculate on that one
Comment 10 jie shen 2004-09-21 16:10:08 EDT
Follow up to comment # 7:

The hardware I referred to in that comment was:

Dell Precision 530 with Dual Xeon processors at 1.8GHZ each,
running Fedora core 2.
Comment 11 Griffin Hernandez 2004-09-22 03:02:19 EDT
I have the same problem on a Intel 840 Dual p3 board.
Havent tried using a non smp kernel.
Currently trying to recompile the kernel..
Comment 12 Bluejay Adametz 2004-11-06 18:21:06 EST
FWIW...

I've got an E7505/P4 hyperthreaded system that, with the 2.6.5-1.358 SMP kernel (from 
the original FC2 distribution), would lose the keyboard after 10 to 12 days. The keyboard 
would just go dead, and only a complete reboot (not power cycle) would bring it back. With 
the non-SMP kernel, it was fine.

I upgraded to the 2.6.8-1.521 SMP kernel and the keyboard has been fine ever since. 
The system has been running without any problem for over 21 days now.

It would seem that something in 2.6.8-1.521 fixed my problem. The question I'm only 
qualified to ask is, was the fix deliberate?
Comment 13 Dave Jones 2005-04-16 01:47:55 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.