Bug 123928 - (IT:44891) Kernel drops packets on tg3 gigabit ethernet interface on Dell PowerEdge 4600
Kernel drops packets on tg3 gigabit ethernet interface on Dell PowerEdge 4600
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: David Miller
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-21 15:28 EDT by Michael
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:25:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael 2004-05-21 15:28:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
When running the kernel-2.4.21-15.ELsmp kernel on a Dell PowerEdge 
4600, the gigabit tg3 interface drops about 5-7% of packets.  I ran a 
ping -f from two machines connected via CAT5 crossover to verify.  
When using the 9.0.3 release of the 2.4.21 kernel, there are no 
problems.

Version-Release number of selected component (if applicable):
kernel-2.4.21-15.EL

How reproducible:
Always

Steps to Reproduce:
1. Run kernel-2.4.21-15.ELsmp
2. ping -f <machine over eth1>
3. See 5-7% dropped packets
    

Actual Results:  5-7% dropped packets

Expected Results:  0% dropped packets

Additional info:
Comment 1 Bastien Nocera 2004-07-05 06:52:28 EDT
Do you see error such as:
Jun  3 11:00:20 os-db01 kernel: tg3: eth0: Link is down.
Jun  3 11:00:22 os-db01 kernel: tg3: eth0: Link is up at 1000 Mbps,
full duplex.

In the output of dmesg? Are you running Oracle on this machine while
doing your tests? If so, it could be a duplicate of bug #123695
Comment 2 Michael 2004-07-05 12:54:56 EDT
Yes, in dmesg,/var/log/messages -- and no, we are not running Oracle, 
only Apache, MySQL, and Postgres.  I believe the newest kernel update 
has resolved this problem, as on one of the machines, I am not 
noticing any more dropped packets.
Comment 4 RHEL Product and Program Management 2007-10-19 15:25:59 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.