Bug 123930 - system-config-network will not start after upgrade to 2.6.6
system-config-network will not start after upgrade to 2.6.6
Status: CLOSED DUPLICATE of bug 122223
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Depends On:
  Show dependency treegraph
Reported: 2004-05-21 15:42 EDT by Quint Van Deman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:03:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Quint Van Deman 2004-05-21 15:42:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
After upgrading FC2 from 2.6.5-1.358 (default) to 2.6.6 to work around
ndiswrapper issue, system-config-network crashes whenever launched.

Component: system-config-network
Version: 1.3.16
Summary: TBf3ca2c97 NC_functions.py:54:kernel_version:ValueError:
unpack list of wrong size
Traceback (most recent call last):
  File "/usr/sbin/system-config-network-gui", line 183, in ?
    from netconfpkg import NC_functions
line 61, in ?
  File "<string>", line 1, in ?
line 28, in ?
line 78, in ?
line 54, in kernel_version
ValueError: unpack list of wrong size

Local variables in innermost frame:
release: 2.6.6-Quint-custom
machine: i686
version: #1 Fri May 21 13:54:29 EDT 2004
nodename: Q-Fedora.atlanta.com
sysname: Linux

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Upgrade kernel to 2.6.6 (from kernel.org)
2. use .config from 2.6.5-1.358 with virtually no changes
3. ensure 4KSTACKS is disabled in .config (reason for kernel upgrade)
4. launch system-config-network

Actual Results:  1. Prompts for root passwd
2. Crashes (trace in description)

Expected Results:  1. Prompt for root passwd
2. Launch system-config-network

Additional info:

Utility worked fine under FC1 and FC2 before upgrading kernel.
Comment 1 Alan Cox 2004-05-21 18:31:52 EDT
I'm unable to duplicate this with a 2.6.6 kernel.

Looking at the code it seems to be because you added an extra "-" in
the release and the config tools don't expect that to happen.
Comment 2 Quint Van Deman 2004-05-23 17:20:00 EDT
That was it...

Recompiled without the dashes in the extra version and everything
returned to perfect condition.

Thanks for the help...
Comment 3 Harald Hoyer 2004-05-24 06:33:57 EDT

*** This bug has been marked as a duplicate of 122223 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:03:25 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.