Bug 123937 - Fedora Core 2 fresh install renders machine unbootable (MBR messed up)
Fedora Core 2 fresh install renders machine unbootable (MBR messed up)
Status: CLOSED DUPLICATE of bug 115980
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-21 16:46 EDT by des johnston
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description des johnston 2004-05-21 16:46:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
An install of FC2 into a pre-existing partition on a machine that
was multibooting winXP, FC1, Debian and Gentoo (from FC1 grub)
rendered the machine unbootable, even though anaconda had been
instructed to not touch the bootloader and Disk Druid only used to set
the mountpoint for the FC2 / . The MBR had to be fixed using sfdisk
and FC1 grub reinstalled to get it booting again.


More details
------------

Hardware: Asus A7N8X-VM/400 Mobo, LBA set to [Auto] (only choices
are [Auto] and [Disabled]), 2 Seagate 80Gb HDDs. AthlonXP 2500+
1GB DDR 333 memory.

Setup before install:

hda: hda1 WinXP installed first, shrunk with Partition Magic
     hda2 FC1 installed second, grub used to boot the rest
     hda3 Debian
     hda4 swap

Second disk installed and partition with FC1

hdb: hdb1 Gentoo
     hdb2  target for FC2 install
     hdb3  empty
     hdb4 swap

FC2 custom install from CD:
partition alignment error message appears (it was there in FC1 install
too), I ignored it again :(

Disk Druid used to set mount point for FC2 / anaconda told to leave
bootloader untouched

The install proceeded to completion without apparent error.

on reboot GRUB hangs at stage 1_5.

This needed to be fixed with the posted sfdisk trick and FC1 grub
re-installed to get the machine to boot again.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC2 on this machine (_not_ upgrade)
2.
3.
    

Additional info:
Comment 1 Don Berberich 2004-05-23 16:42:56 EDT
I had this exact problem.  I resolved this by setting the HD mode to
LBA.  The system boots normally after this change.
Comment 2 Paul Stevens 2004-06-08 06:08:23 EDT
I had a similar problem as well. I originally had FC1 installed
/dev/hda3 with /boot & grub on there as well. W2k was on /dev/hda1.    

I used the upgrade option with FC2 and rebooted.. the machine could
not boot into anything and just said something like "Grub Stage 2
Loading".   Tried reinstalling and FC2 and installing grub on
/dev/hda3, didn't work.   

I used windows XP to install a new MBR and re-'installed' FC2. Then
used the windows bootloader to load FC2.
Comment 3 Bob Fourney 2004-06-21 15:36:52 EDT
If by "unbootable" you include not bootable via floppy or CD (so long
as the hard drive is connected), I've got the same problem.  Once I
install Fedora Core 2, the system attempts to reboot and I get the
"F10 to boot, F2 for BIOS" screen, but it is dead.  Nothing can get it
off of this screen.  Power cycling w/ a rescue CD in  and it still
freezes. It will not boot, even from floppy or CD until the hard drive
I installed FC on is unplugged.  Trying the published trick w/
changing the head count (using another machine to modify the partition
table of this harddrive), and/or installing by giving he CHS info up
front gives the same result.  The only way that disk is usable is to
take it to an older machine, boot from a floppy, and remove the
partitions.  Then I can install again (and I have, many times).  I've
done this with 2 different Western Digital (WD800BB) drives.


Offending machine is a new Gateway E6100, P4, 3G, 512 M of RAM, BIOS
version # BZ87510A.15A.0114.P13.   Gateway has a BIOS version with a
later date, but the same # on their site.  It doesn't help, and the
nice lady at gateway confirms that it is the same.  If there is an LBA
option under this BIOS we can't find it.

I tried this with and without XP already on the disk.  I tried doing
the "head change", and tried giving it that info up front.  I
re-loaded the BIOS anyway (before talking to gateway).  No dice w/ FC
2 on this machine.

I did re-load XP + patches and then install FC 1.  No problems, works
as expected.  

I tried to boot off of this hard-drive (after one of the installs)
using another machine.  It tries to load an boot, before choking on
the fact that all the hardware doesn't match the drivers.  [That
machine, A P3 (gateway E4200), model # TBR500, BIOS version
4M4PBOX1.15A.0026.P14  

That is also the box used to remove the partitions prior to trying
again.  

(Jeremy, if this is a totally different bug, let me know where to
submit it.  I suspect there is a slight problem with the BIOS on the
gateway [since it should boot off of the CD even if the HD melts] AND
a slight new problem with the installation of FC 2 [since it's messing
up the HD)


           Thanks,


           Bob Fourney
Comment 4 Alan Tutt 2004-09-27 18:23:58 EDT
Many of the comments here are the same as my situation, although I 
didn't see the exact same thing, so I'll include my case here as well.

I started out with a Windows XP Home system with a 200GB main disk 
(/dev/hda).  Windows XP was given the first partition of 80GB (NTFS), 
leaving 120GB unassigned for the Fedora install.

The install process went smoothly enough, although there was a 
message about the partition table not matching what was expected.  
The box said that it was safe to ignore the message, so I did.

At the stage where the GRUB settings are entered, I chose to have 
Windows XP as the default OS.  Not knowing to set anything different, 
I left all other settings as they were.

After installation, Fedora booted up just fine.  I explored the 
system a bit, and then rebooted the system to bring up WinXP.  No 
luck.  I got to GRUB, which then displayed the 'chainloader +1' line, 
and then the system froze.

Thinking that the issue with the partition table must have caused the 
problem, I went to boot up a CD for configuring the harddrive, but 
the system would not boot to the CD.  I got a message about Caldera 
DR-DOS loading, but then the system froze.

I tried booting to a floppy (to run Norton Ghost to attempt to 
recover my Windows partition), but the same result.  A message about 
PC-DOS loading, but nothing afterwards.

In both cases, I left the system hanging for about 5 minutes before 
giving up.

Next, I tried booting up into Fedora again, and that worked without a 
glitch.

I also tested booting up the Fedora Rescue CD, and that also worked.

Next, I switched the harddrive and replaced it with a 'clean' one, 
with a single Windows XP partition (NTFS).  Again, I was unable to 
boot to either floppy nor CD, except for the Fedora CDs.

At this point, I realized that the problem was not on the harddrive, 
but elsewhere in the system.  The BIOS perhaps?  What did Fedora 
change in my system to stop it from booting from either DOS or 
Windows, but allow it to boot to Fedora?

This seems like deliberate sabotage to me.

Any comments or offers to help restore my system may be addressed to 
powerkeys@comcast.net.

- Alan
Comment 5 Jeremy Katz 2004-10-07 14:21:49 EDT

*** This bug has been marked as a duplicate of 115980 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:03:25 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.