Bug 123941 - gnome evolution description/tooltip jp translation bad
gnome evolution description/tooltip jp translation bad
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: redhat-menus (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
: i18n
Depends On:
Blocks: FC2Update
  Show dependency treegraph
 
Reported: 2004-05-21 17:17 EDT by Eido Inoue
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-21 06:36:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eido Inoue 2004-05-21 17:17:04 EDT
Description of problem:
The jp translation of the description for Evolution under GNOME is
missing a word

How reproducible:
always

Steps to Reproduce:
1. Install a JP capable FC2
2. Run GNOME in JP mode
3. Either hover other the mail icon in the GNOME panel under the
tooltip with the description appears, or look at the program
name/description for the インターネット sub-menu from the main menu.
  
Actual results:
"の電子メール"

Expected results:
"Evolutionの電子メール"

Additional info:
There seems to be two program launchers for Evolution under インター
ネット ... one for Evolution with the Japanese description done
correctly, and another for "launchmail" (which launches Evolution)
which has the bad jp translation/description.
Comment 1 Dave Malcolm 2004-05-24 12:17:48 EDT
Can you tell me which package is providing the "launchmail" launcher?
Comment 2 Eido Inoue 2004-05-24 12:21:52 EDT
Comment 1: 
> Can you tell me which package is providing the "launchmail" launcher?



htmlview-3.0.0-4. I guess the bug needs to be changed to that
component perhaps.
Comment 3 Dave Malcolm 2004-05-24 13:50:59 EDT
Are you sure?  The "htmlview' package seems to be a launcher for
Mozilla, not Evolution
Comment 4 Eido Inoue 2004-05-24 14:38:44 EDT
Comment 3:
> Are you sure?  The "htmlview' package seems to be a launcher for
Mozilla, not Evolution

$ rpm -qf /usr/bin/launchmail
htmlview-3.0.0-4

$ /usr/bin/launchmail

(Evolution appears)
Comment 5 Dave Malcolm 2004-05-24 15:14:50 EDT
OK - launchmail was added to htmlview-3.0.0 in version 4 (I was
looking at version 3).  I believe it's a symlink to a .desktop file in
the redhat-menus package.  Changing component to "redhat-menus"
Comment 6 Eido Inoue 2004-05-24 15:33:07 EDT
For the benefit of the pkg maintainer if they don't read Japanese:

the resulting translation (ommision of the word "Evolution") is not
just a proper branding problem; it's an embarrassing miss in that it's
grammatically incorrect and in-your-face in the main internet menu and
on the gnome-panel at startup.

Current translation is roughly equivalent to:

"'s e-mail"
Comment 7 Warren Togami 2004-05-24 16:44:42 EDT
This is my fault.  The following I believe needs to be done in order
to fix this:

1) Split the .pot into two files, one for evolution and another for
generic mail.  (Probably do the same for Mozilla and generic browser
too.)  I am not entirely sure how to do this so I would appreciate if
a i18n developer can walk me through this.
2) Issue a redhat-menus package update.
Comment 8 Warren Togami 2004-05-24 17:29:23 EDT
Havill asked why we need two:
1) Panel launchers need the generic launchers.
2) Menus minimally should have specific app launchers.
3) Generic and specific launchers are NOT the same thing.

Also note that the Epiphany launcher needs yet another split translation.
Comment 9 Warren Togami 2004-06-15 20:01:03 EDT
I do not consider this issue alone to be good reason to push an update
for redhat-menus.  If other issues in redhat-menus are identified and
corrected, then a package update can be issued which solves this and
the other issues.
Comment 10 Warren Togami 2004-07-12 04:56:20 EDT
After discussing this a bit with the desktop team, they took offense
to there being two menu options for "Web Browser" after this change. 
Removing the generic launchers for "Web Browser" and "E-mail" from FC3
in addition to fixing this bug in  the Japanese translation.

The .po file for redhat-menus needs to be changed and translations
fixed the correct way.  I am guessing both the .po and .pot files are
on elvis, but I have no idea where... anyone?
Comment 11 Warren Togami 2004-07-12 05:03:47 EDT
Arg... no I am wrong.  It still needs to split into two different
strings in the .po because the generic launcher is for the default panel.
Comment 12 Warren Togami 2004-10-21 06:36:03 EDT
Comment #10 and #11 correct implementation with .po files was done by
jrb for FC3.  This is not worth fixing for FC2.

Note You need to log in before you can comment on or make changes to this bug.