Bug 123953 - Dell inspiron 5000 shows blank screen when Xorg-X11 starts
Dell inspiron 5000 shows blank screen when Xorg-X11 starts
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-21 18:50 EDT by Michael Jones
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-06 16:42:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The xorg.conf file created during install (2.68 KB, text/plain)
2004-05-21 20:25 EDT, Michael Jones
no flags Details
Dell 8000 install crash - anacdump.txt (39.54 KB, text/plain)
2004-05-22 23:00 EDT, Michael Jones
no flags Details
X.log from the FC3test2 installation process (found in /tmp/ramfs/X.log) (38.91 KB, text/plain)
2004-09-21 16:55 EDT, Valentin Guggiana
no flags Details

  None (edit)
Description Michael Jones 2004-05-21 18:50:25 EDT
Description of problem: Did an upgrade from FC1 to FC2 on a Dell
Inspiron 5000 laptop, 600/500Mhz / 384MB RAM / ATI Rage Mobility /
20GB hdd / Zoom 2975LA Modem card / Netgear FA510 Network card ...
Installation went well, although could only do a text install,
graphical would not work, then after reboot during the graphical boot,
the screen goes blank... i took a guess and typed my login/password
and the hdd starts spinning like it is loading the desktop, but is
still blank. I CTRL+ALT+F2 to console, logged in as root, checked the
logs and the Xorg.0.log shows the X11 started no problem no errors.

I turned off the graphical boot, and changed init from 5 to 3 and
system reboots into text mode, works fine... noticed there was no
xorg.conf after upgrade so I copied the X86Config to xorg.conf and
tried to play around and no amount of noodlin was able to make it
work, but I was able to get it to fail by removing features etc.

I tried booting with 'acpi=no' and 'nofb' and this did not change
anything.

I got the results from a fresh install.

I downloaded the XFree86 binaries, installed them and they produced
the exact same results... X starts, but screen remains blank.

Version-Release number of selected component (if applicable): Fedora
Core 2, shipping version of xorg-* files.


How reproducible: With Upgrade and fresh install.


Steps to Reproduce:
1. install/upgrade a dell inspiron 5000 laptop with FC2
2.
3.
  
Actual results:

Screen remains blank on successful X startup.


Expected results:

That I would see the joyous new Fedora Core 2 desktop in vivid
1400x1050 color as has always been the case with this laptop since I
bought it 4 years ago and loaded RH6.2 on it. :)

Additional info:

I though it might be a hardware issue, but have now seen several
reports of other Dell laptops doing the exact same thing on the
fedora-list. I have not read any reported workarounds other than
reinstalling FC1.
Comment 1 Michael Jones 2004-05-21 20:25:13 EDT
Created attachment 100440 [details]
The xorg.conf file created during install

Here is the xorg.conf from my Dell Inspiron 5000 install of FC2
Comment 2 Michael Jones 2004-05-22 22:04:37 EDT
I just took my wife's Dell Inspiron 8000 w/ ATI Rage 128 Mobility 
card and replaced the hhd with one of mine and tried to install FC2 
and got the exact same results... when trying to do a graphical 
install the screen just blanks and that is is that. I tried booting 
with 'linux nofb' and same result. 
 
I am going to try a text install and then keep trying to play with 
the xorg.conf to see if I can get Xorg-X11 to work. 
Comment 3 Michael Jones 2004-05-22 23:00:42 EDT
Created attachment 100467 [details]
Dell 8000 install crash - anacdump.txt

During my Dell 8000 install, it crashed and told me to post this file.
Comment 4 Michael Jones 2004-05-24 00:20:15 EDT
I finally got it working! I did a text install, and after the 
install and on first reboot, i changed the kernel line (in Grub) 
from 'rhgb quiet' to 'vga=791'. I also changed the HorizSync to 
30-100 and VertRefresh to 50-100, choose "LCD 1400x1050" during the 
install. 
 
I was also able to get the graphical instll screen to come up by 
using the 'linux vga=791' when booting form the first install CD. 
Comment 5 David W. Legg 2004-06-08 15:00:53 EDT
THanks. The linux vga=791 certainly seems to allow me to do a
graphical install on my Inspiron 7500 PII 400MHz ATI Rage Mobility
64MB. I just need a bit of time to try and fix the same problem with
my actual FC2 disk in the machine.

The ATI drivers worked fine under RH 9. Don't know about FC 1, but are
broken in FC 2, by the looks of things.
Comment 6 David W. Legg 2004-06-12 15:57:35 EDT
Yep, your fix to the grub.conf file works on the Inspiron 7500 too.
Comment 7 Valentin Guggiana 2004-09-21 16:55:19 EDT
Created attachment 104088 [details]
X.log from the FC3test2 installation process (found in /tmp/ramfs/X.log)

Problem still exists with FC3test2. I attached X.log from installation process.
Comment 8 David W. Legg 2005-01-15 16:57:10 EST
Anaconda now starts in graphical mode ok in Fedora Core 3.

However, after the installation is complete, the first boot fails to
come up in X because the vga=792 has not been appended to the end of
the relevant line in /etc/grub.conf.

Doing this manually and rebooting fixes the problem.
Comment 9 Mike A. Harris 2005-03-06 16:42:33 EST
Since this bugzilla report was filed, there have been several major
updates to the X Window System, which may resolve this issue.  Users
who have experienced this problem are encouraged to upgrade to the
latest version of Fedora Core, which can be obtained from:

        http://fedora.redhat.com/download

If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "CURRENTRELEASE".

Note You need to log in before you can comment on or make changes to this bug.