Bug 123961 - Master volume 'steps' down to zero
Master volume 'steps' down to zero
Status: CLOSED DUPLICATE of bug 121376
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-21 23:53 EDT by Justin Georgeson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Justin Georgeson 2004-05-21 23:53:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
After installing Fedora Core 2 on an IBM Thinkpad 600X, type 2645-5EU,
the sound controller was properly detected. Upon logging into gnome,
the volume for all channels was set to zero, as expected. The main
problem I am having is that setting the volume of the Master channel
(the Alsa Master channel) using the panel applet does not work. If I
single left click on the applet to get the volume slider and set a
volume, the setting has no effect on currently playing audio, and the
volume creeps back down to zero. If I open the Volume Control app and
set the volume on the Master channel in the Alsa tab, that works, and
the volume stays where I set it. Likewise with the corresponding OSS
channel, called Volume instead of Master.

Opening up the "Volume Control" application (gnome-volume-control)
from the mixer panel applet, I see there are two modules I can
control: "Sound Fusion CS46xx [Alsa Mixer]" and "Cirrus Logic CS4297A
rev 3 [Audio Mixer (OSS)]." The Alsa tab has 41 channels to control.
The OSS tab has 13, all of which appear in the Alsa tab. Changes to
these common channels do not appear to be reflected across tabs (set
PCM to a certain level in OSS, and the PCM channel does not show the
same change in Alsa, but changes made to PCM in either tab take
immediate effect, so no big deal there).

Version-Release number of selected component (if applicable):
gnome-applets-2.6.0-5

How reproducible:
Always

Steps to Reproduce:
1. Assuming a right-naded mouse configuration, single left click on
the volume control applet to get volume slider
2. Set volume to any nonzero setting

    

Actual Results:  Volume set in step 2 is never effected, and volume
creeps down to zero by itself

Expected Results:  Setting should take effect and stay at specified level

Additional info:
Comment 1 petrosyan 2004-05-22 00:53:16 EDT
I see exactly the same bug on ThinkPad T20
Comment 2 Elijah Newren 2004-05-22 12:03:49 EDT
This is a duplicate of bug 121376, which in turn is a duplicate of the
upstream http://bugzilla.gnome.org/show_bug.cgi?id=139961, which is
fixed in gnome-applets-2.6.1.  I have links to some updated rpms that
work for me in bug 121376.
Comment 3 Justin Georgeson 2004-05-22 13:34:58 EDT
Thanks Elijah, the 2.6.1 RPM on that site fixed things for me too.
Comment 4 Miloslav Trmac 2004-07-11 09:40:39 EDT

*** This bug has been marked as a duplicate of 121376 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:03:30 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.