Bug 123964 - Volume level at zero when system is restarted.
Volume level at zero when system is restarted.
Status: CLOSED DUPLICATE of bug 126212
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-22 01:00 EDT by Steve Sether
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Sether 2004-05-22 01:00:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
My Dell Latitude CSx with Neomagic NM2360 audio is having problems
with restoring sound settings after I upgraded from FC1.  Sound
remains muted and at zero volume when X is restarted.  I don't know
how sound settings are normally restored, but when I  runn alsactl
restore it gives the following error message:

alsactl: set_control:966: Cannot write control '2:0:0:CD Playback
Switch:0' : Invalid argument

removing the line associated with this setting in /etc/asound.state
then produces this error message:

alsactl: set_control:966: Cannot write control '2:0:0:CD Playback
Volume:0' : Invalid argument

Removing the line associated  with this setting then allows alsactl to
run properly, and the sound setting gets restored (and sound works).
Unfortunately alsactl writes an improper save file again when the
machine is shut down, and the problem repeats itself.  

Workaround:  run alsactl --force restore restore and the error
messages are still generated, but the sound settings are set properly.

Does alsactl restore the settings?  If so where does it do it?  This
machine doesn't have a CD-ROM, so I assume that might be the source of
the problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Login
2. Adjust sound levels via Volume Control
3. Play sound, hear sound.
4. Restart machine.
5. Login again.
6. Try to play a sound (I was using mplayer, but the system sounds
don't play as well)
7. Sound doesn't play.
    

Actual Results:  Silence

Expected Results:  The sound to play.

Additional info:

Dell Latitude CSx with Neomagic NM2360 audio.
Comment 1 Brent Fox 2004-06-17 12:11:46 EDT

*** This bug has been marked as a duplicate of 126212 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:31 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.