Bug 12398 - cyrillic fonts install & KDE
Summary: cyrillic fonts install & KDE
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-17 19:59 UTC by Sergey
Modified: 2007-04-18 16:27 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-11 07:11:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sergey 2000-06-17 19:59:15 UTC
I've just installed RH6.2 , choosing Russian as the def. language.
Unlike in RH6.1 6.0 5.2 , now cyrillic fonts are installed in this case -
very well, and in GNOME the things, that should be in Russian are in
Russian, but in KDE there is another picture - unreadable symbols instead
of russian symbols, - because KDE doesn't see russian fonts (KDE's bug).

But this problem can be easily overcomed -  in /etc/X11/fs/config file , in
the catalogue section, move the string  /usr/X11R6/lib/X11/fonts/cyrillic,
to the first place.
After installation this section was  :

catalogue = /usr/X11R6/lib/X11/fonts/misc:unscaled,
	/usr/X11R6/lib/X11/fonts/75dpi:unscaled,
	/usr/X11R6/lib/X11/fonts/misc,
	/usr/X11R6/lib/X11/fonts/Type1,
	/usr/X11R6/lib/X11/fonts/Speedo,
	/usr/X11R6/lib/X11/fonts/cyrillic,
	/usr/X11R6/lib/X11/fonts/75dpi,
	/usr/share/fonts/default/TrueType,
	/usr/share/fonts/default/Type1

It needs to be :

catalogue = /usr/X11R6/lib/X11/fonts/cyrillic,
	/usr/X11R6/lib/X11/fonts/misc:unscaled,
	/usr/X11R6/lib/X11/fonts/75dpi:unscaled,
	/usr/X11R6/lib/X11/fonts/misc,
	/usr/X11R6/lib/X11/fonts/Type1,
	/usr/X11R6/lib/X11/fonts/Speedo,
	/usr/X11R6/lib/X11/fonts/75dpi,
	/usr/share/fonts/default/TrueType,
	/usr/share/fonts/default/Type1

In this case KDE sees cyrillic fonts, and menus are OK.
As far as I understand , XFree86-cyrillic-fonts-3.3.6-20.i386.rpm, must be
installed after all other fonts are installed. (maybe except misc)

Comment 1 Brock Organ 2000-06-17 23:01:16 UTC
thanks for your report!  I will forward this to the KDE folks ...

Comment 2 Bernhard Rosenkraenzer 2000-11-03 09:27:47 UTC
Please check if this still occurs with the current version (2.0).

Comment 3 Sergey 2000-11-11 07:11:25 UTC
The bug disappeared in KDE2.0 ( Currently using xfree 4.0.1 binaries from
xfree.org + manually compiled KDE2)


Note You need to log in before you can comment on or make changes to this bug.