Bug 123986 - rhytmbox hangs when stopping a remote audio stream
rhytmbox hangs when stopping a remote audio stream
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-22 10:43 EDT by Justin Georgeson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-07 16:10:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Georgeson 2004-05-22 10:43:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
The same problem existed in Fedora Core 1 too. I have
rhythmbox-0.8.3-3 and gstreamer-0.8.1-1, along with
gstreamer-plugins-0.8.1-1, gstreamer-plugins-mp3-0.8.1-0.lvn.1.2 (from
livna.org) and libmad-0.15.1-0.lvn.1.b.2 (also from livna.org). When
listening to a remote stream (like any station from shoutcast.com) in
rhythmbox, hitting the stop button hangs rhythmbox. It me be forced to
exit (kill -9, hitting the window managers close button a bunch of
times, using the system monitor). Switching streams works just fine,
it's just hitting stop that hangs it. I realise MP3 is not supported
by RedHat, point me to a stream for a supported type and I will try to
reproduce it with that.

I have an RHEL WS 2.1 box with gstreamer and rhythmbox installed using
the original source (via garnome) and I don't think the problem exists
there. 

Version-Release number of selected component (if applicable):
rhythmbox-0.8.3-3

How reproducible:
Always

Steps to Reproduce:
1. Play a radio station in rhythmbox
2. Hit the stop button
    

Actual Results:  rhytmbox hangs and must be forcibly killed

Expected Results:  the stream should stop playing

Additional info:
Comment 1 Colin Walters 2004-09-07 16:10:35 EDT
I'm pretty sure this is because Rhythmbox is trying to shut down the
TCP connection when you click stop, but the other side isn't responding.
This is thus a symptom of the larger issue of needing to make internet
radio asynchronous, already reported upstream:

http://bugzilla.gnome.org/show_bug.cgi?id=128106

Note You need to log in before you can comment on or make changes to this bug.