Bug 124002 - not all of devel files are included
not all of devel files are included
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: compat-db (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-22 15:57 EDT by William M. Quarles
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-24 10:45:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Porting to DB v4.2.52 (786 bytes, patch)
2004-08-08 10:38 EDT, Jeff Pitman
no flags Details | Diff

  None (edit)
Description William M. Quarles 2004-05-22 15:57:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
You guys forgot to include all of the devel files in this compat
package.  These are very necessary for those of us who compile
programs from scratch that are written for older versions of Berkley
DB (yes, not all of us use RPM exclusively).

Version-Release number of selected component (if applicable):
compat-db-4.0.14-2

How reproducible:
Always

Steps to Reproduce:
1.N/A
    

Actual Results:  http://www.squidguard.org/
As an example, here is a well-maintained program that I need to
install that specifically requires db2.  I can't because half of the
devel files are missing from compat-db

Expected Results:  I should have been able to compile this.
Comment 1 Jeff Johnson 2004-05-24 10:45:55 EDT
compat-db is not intended to supply a devel environment, only
the sonames and libraries necessary for legacy compatibility.

Port to db-4.2.52, not hard.
Comment 2 Jeff Pitman 2004-08-08 10:38:00 EDT
Created attachment 102505 [details]
Porting to DB v4.2.52

If you're still scratching your head about squidguard, here's a small tip of
what I had to do to forward port Python 1.5.2 to compile against db4 4.2.52.

Note You need to log in before you can comment on or make changes to this bug.