Bug 124016 - rpm silently ignores PackageName.NotInstalledArch
Summary: rpm silently ignores PackageName.NotInstalledArch
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: Reopened
: 230580 234601 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-22 22:54 UTC by Nicholas Miell
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-26 07:51:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nicholas Miell 2004-05-22 22:54:50 UTC
rpm -q PackageName.NotInstalledArch should report "package PackageName
is not installed" instead of being silent.

I noticed this when I was trying to figure out why I couldn't remove
openssl.i386 on an AMD64 system (which had openssl.i686 and
openssl.x86_64 installed) -- all references to openssl.i386 were
silently ignored.

Comment 2 Jeff Johnson 2006-03-01 14:14:17 UTC
Use the exact arch. Trying to compute all possible compatible arches is not worth the effort.
Consider for example hosting on a server, or using a qemu emulator: exactly what arches are
"compatible" and hos the heck is rpm supposed to discover "compatible"?!?

Comment 3 Nicholas Miell 2006-03-01 18:53:45 UTC
I'm not complaining about RPM failing to infer that i686 is i386, I'm
complaining that RPM doesn't say *anything at all* when you mistakenly list an
architecture that isn't installed for a package that is.

i.e.

[nicholas@entropy ~]$ rpm --nevra -qa openssl*
openssl097a-(none):0.9.7a-3.1.x86_64
openssl-(none):0.9.7f-7.10.x86_64
openssl-devel-(none):0.9.7f-7.10.x86_64
openssl-(none):0.9.7f-7.10.i686
[nicholas@entropy ~]$ rpm -q openssl.i386
[nicholas@entropy ~]$

The bug is the complete lack of output between the last two shell prompts. I'd
expect "package openssl is not installed" at the very least or "package
openssl.i386 is not installed" if you feel like fixing it right.

Comment 4 Jeff Johnson 2007-01-04 03:28:52 UTC
Fixed in rpm cvs, will be in rpm-4.4.8-0.9 when built.

UPSTREAM

Comment 5 Red Hat Bugzilla 2007-02-05 18:57:15 UTC
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.

Comment 6 Panu Matilainen 2007-06-11 10:24:42 UTC
Fixed in rpm.org now, will be in 4.4.2.1

Comment 7 Panu Matilainen 2007-06-11 14:28:33 UTC
*** Bug 230580 has been marked as a duplicate of this bug. ***

Comment 8 Panu Matilainen 2007-06-11 14:32:53 UTC
*** Bug 234601 has been marked as a duplicate of this bug. ***

Comment 9 Jeff Johnson 2007-06-23 11:59:06 UTC
CLOSED

Comment 10 Panu Matilainen 2007-06-26 07:51:52 UTC
Fixed in next rawhide push by rpm 4.4.2.1-rc1 


Note You need to log in before you can comment on or make changes to this bug.