Bug 124030 - Anaconda crashes on doPostInstall with /dev/null Input/output error
Anaconda crashes on doPostInstall with /dev/null Input/output error
Status: CLOSED DUPLICATE of bug 124029
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-22 20:57 EDT by Dag Wieers
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dag Wieers 2004-05-22 20:57:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Galeon/1.3.14

Description of problem:
After installing Fedora Core 2, when packages are done. I get the
following error with Anaconda:

  Traceback (most recent call last):
    File "/usr/lib/anaconda/gui.py", line 1048, in handleRenderCallback
      self.currentWindow.renderCallback()
    File "/usr/lib/anaconda/iw/progress_gui.py", line 242, in
renderCallback
      self.intf.icw.nextClicked()
    File "/usr/lib/anaconda/gui.py", line 763, in nextClicked
      self.dispatch.gotoNext()
    File "/usr/lib/anaconda/dispatch.py", line 169, in gotoNext
      self.moveStep()
    File "/usr/lib/anaconda/dispatch.py", line 237, in moveStep
      rc = apply(func, self.bindArgs(args))
    File "/usr/lib/anaconda/packages.py", line 1125, in doPostInstall
      devnull = os.open("/dev/null", os.O_RDWR)
  OSError: [Errno 5] Input/output error: '/dev/null'

This is on a x86_64 system with a custom package selection. I'm now
going to try the default installation.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. ...
2.
3.
    

Additional info:
Comment 1 Arenas Belon, Carlo Marcelo 2004-05-23 12:36:54 EDT
dup of bug 124029
Comment 2 Dag Wieers 2004-05-23 13:45:29 EDT

*** This bug has been marked as a duplicate of 124029 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:03:35 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.