This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 124032 - a default browser with "htmlview" in the name is not allowed
a default browser with "htmlview" in the name is not allowed
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: htmlview (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-22 21:12 EDT by David Baron
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-25 03:15:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Baron 2004-05-22 21:12:49 EDT
Description of problem:
A default browser with "htmlview" in the name is forbidden.  The user
interface displays a dialog that says that the default browser is an
invalid browser, but doesn't say why.

There are three problems here:
 * the restriction is probably too specific (you want to restrict to
the entire basename being "htmlview", not having "htmlview" within the
name)
 * the error dialog gives no hint about why the browser is invalid
 * the error dialog gives no hint about what program is bringing up
the error dialog (which wouldn't be a problem if the previous point
weren't a problem)

Version-Release number of selected component (if applicable):
htmlview-3.0.0-4

How reproducible:
Always

Steps to Reproduce:
1. Create a brower shell script called htmlviewrc.
2. Make it the default browser in Preferences | Preferred Applications
3. Launch a URL from gnome-terminal
  
Actual results:
Error dialog.

Expected results:
Launch browser.

Additional info:
Why do I care?  I have an old .htmlviewrc file that stands fully on
its own -- i.e., it executes the browser and terminates when sourced,
and I tend to configure it as the default browser instead of htmlview
(and now need to, due to changes in htmlview and htmlview's general
lack of X-Remote support).  And I really want it to be my default
browser.  I didn't enjoy having to spend fifteen minutes poking around
and reading /usr/bin/htmlview to figure out why my choice of default
browser was invalid and that the solution was renaming my script.
Comment 1 Warren Togami 2005-04-25 03:15:17 EDT
Sorry no.  .htmlviewrc is irrelevant with modern software.  X-Remote support is
no longer a problem as it is dealt with each browser's launching script.
Comment 2 David Baron 2005-04-26 16:38:44 EDT
If it's irrelevant, then why is it still used?  This is a bug in
/usr/bin/htmlview , and I wouldn't have hit it if it were not used.

(My .htmlviewrc file does a lot of things that I still actually need, mostly
related to which of my Mozilla development trees and which profile I should
currently be using as my default browser.)
Comment 3 Warren Togami 2005-04-26 20:20:19 EDT
Few people if anyone uses .htmlviewrc, and the modern htmlview completely avoids
that codepath for normal desktop usage.  Consider it deprecated.

And was .htmlviewrc ever meant to be executable itself?  That seems extremely odd.
Comment 4 David Baron 2005-04-26 20:46:05 EDT
(In reply to comment #3)
> Few people if anyone uses .htmlviewrc, and the modern htmlview completely
> avoids that codepath for normal desktop usage.  Consider it deprecated.

Fine with me.  If the error message *says* that it's deprecated (i.e., says that
the problem with the browser is that part of its filename is "htmlview" or
"gnome-open"), then I'd consider this bug fixed adequately.

I vaguely remember that there was a version when the only way to do anything
useful with .htmlviewrc was to have it do the execution, due to some other bug
in htmlview.

Note You need to log in before you can comment on or make changes to this bug.