Bug 124039 - <Home> and <End> keys don't function as expected
<Home> and <End> keys don't function as expected
Status: CLOSED DUPLICATE of bug 122815
Product: Fedora
Classification: Fedora
Component: ncurses (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Eido INOUE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-23 00:02 EDT by Marc Williams
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marc Williams 2004-05-23 00:02:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
The <Home> and <End> keys in Less should take you to the beginning and
end of a document respectively just as the <g> and <G> keys do. 
Rather, <Home> and <End> seem to be non-functioning.

It looks like the Less man page and the Less web site both claim that
<Home> and <End> should work as described above.

I believe that in FC1 these keys did work correctly but now that FC2
has taken its place there's no way for me to check for certain.

Version-Release number of selected component (if applicable):
382

How reproducible:
Always

Steps to Reproduce:
1.Open Less in a console
2.Attempt to go to the start or end of a document using <Home> or
<End> key
3.
    

Actual Results:  <Home> and <End> are non-functioning

Expected Results:  <Home> and <End> should function the same as the
<g> and <G> keys and navigate to the beginning and end of the document.

Additional info:
Comment 1 Marc Williams 2004-05-23 08:26:16 EDT
I should add that this only happens in Gnome-terminal and xterm, not a
full screnn console.
Comment 2 Karsten Hopp 2004-05-24 05:39:25 EDT
looks like a regression in ncurses-5.4. A downgrade to ncurses-5.3 
fixes this. 
Comment 3 Joe Orton 2004-05-26 05:30:23 EDT

*** This bug has been marked as a duplicate of 122815 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:03:35 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.