Bug 124043 - cvs diff -uN generates bogus diffs
cvs diff -uN generates bogus diffs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cvs (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-23 01:20 EDT by Ralf Corsepius
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-10 05:01:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2004-05-23 01:20:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
With GCC's CVS repository,
cvs co -rgcc_3_4_0_release 
cvs diff -uN -rgcc_3_4_0_release 
generates bogus diffs.

Version-Release number of selected component (if applicable):
cvs-1.11.15-1

How reproducible:
Always

Steps to Reproduce:
1. Check out a copy gcc-3.4.0 from GCC's CVS (cf. http://gcc.gnu.org)
cvs co -r gcc_3_4_0_release

2. Run
cvs diff -uNR -r gcc_3_4_0_release


Actual Results:  The resulting diff contains diffs against files that
try to remove files that are not present in gcc_3_4_0_release.

Example: 
cvs diff -uN -r gcc_3_4_0_release gcc/config/sparc/t-linux
Index: gcc/config/sparc/t-linux
===================================================================
RCS file: gcc/config/sparc/t-linux
diff -N gcc/config/sparc/t-linux
--- gcc/config/sparc/t-linux    1 Apr 2004 16:13:08 -0000       1.3.2.2
+++ /dev/null   1 Jan 1970 00:00:00 -0000
@@ -1,2 +0,0 @@
-# Compile libgcc2.a with pic and IEEE quad long double.
-TARGET_LIBGCC2_CFLAGS = -fPIC -mlong-double-128

As it seems to me these are files had both been tagged
"gcc_3_4_0_release" and had been "cvs rm"'ed.


Expected Results:  The diff should be empty. 

Additional info:

I had tried to file this as a PR into GCC's bugzilla, but the GCC
maintainers blame "my cvs to be broken".

cf.: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=15564
Comment 1 Ralf Corsepius 2004-05-26 12:27:33 EDT
Seems to be fixed with cvs-1.11.15-5

Note You need to log in before you can comment on or make changes to this bug.