Bug 124046 - ASUS P4E cdrom code oopses
ASUS P4E cdrom code oopses
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Alan Cox
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-23 01:52 EDT by James Peeples
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 00:58:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Peeples 2004-05-23 01:52:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
OS is Fedora Core 2.  Platform is 2.4 GHz Pentium IV running on an 
Asus P4PE motherboard with 512 MB RAM, nVidia geForce 5600-256MB AGP 
video, Creative Audigy sound.

On booting Fedora Core 2, boot continues normally until immediately 
after entering interactive startup and mounting root read-write.  
System becomes nonresponsive and about 2 minutes later produces this 
error:

<0>Kernel Panic: Fatal exception in interrupt
In interrupt handler - not syncing

This system ran Fedora Core 1 with no difficulties.  Have also tried 
Mandrake 10 (community release), it also freezes with same error.

Thank you.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Fedora Core 2 on P4PE motherboard, 512 MB RAM, P4-2.4 CPU.
2.Install goes normally but kernel panics when booting into Fedora.
3.
    

Actual Results:  Immediately after mounting root read-write, system 
freezes, then produces error:

<0> Kernel Panic: Fatal exception in interrupt
In interrupt handler - not syncing



Expected Results:  System should boot into Linux normally.  This 
exact system ran Fedora Core 1 with no difficulty.

Additional info:

Mandrake 10 community release exhibits same behavior.
Comment 1 James Peeples 2004-05-24 03:24:37 EDT
Here is the panic screen text:

Process swapper (pid: 0,threadinfo=02344000 task=022c5aa0)

Stack: a037a234 0237a234 00000080 00008000 021ffb53 0000eab0 021ff9f6 
00000000
       00000000 0237a234 00126400 00000000 02200f86 21de0e00 03573a78 
03573a78
       0237a234 00126400 00000000 021f54a6 00126400 00000000 0000000f 
03573a78

Call Trace:
  [<021ffb53>] cdrom_start_packet_command+0x110/0x134
  [<021ff9f6>] cdrom_timer_expiry+0x0/0x4d
  [<02200f86>] ide_do_rw_cdrom+0xe3/0x14f
  [<021f54a6>] start_request+0x198/0x169
  [<021f571e>] ide_do_request+0x23d/0x278
  [<021f5972>] ide_timer_expiry+0x152/0x15e
  [<021f5820>] ide_timer_expiry+0x0/0x15e
  [<0211de03>] run_timer_softirq+0x106/0x12a
  [<0211afbd>] __do_softirq+0x35/0x73
  -------------------------
  -------------------------
  [<0210737b>] do_IRQ+0x15d/0x169
  [<0210403b>] default_idle+0x23/0x26
  [<0210408c>] cpu_idle+0x1f/0x34
  [<02318612>] start_kernel+0x174/0x176

Code: 0f 0b eb 03 59 73 2a 02 89 0a 86 44 24 18 89 82 e4 00 00 00
 <0>Kernel panic: Fatal exception in interrupt
In interrupt handler - not syncing
Comment 2 Dave Jones 2005-02-24 00:45:08 EST
did fc3 fare any better ?
Comment 3 Dave Jones 2005-04-16 00:58:26 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.