Bug 124047 - fail to parse kernel version
fail to parse kernel version
Status: CLOSED DUPLICATE of bug 122223
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-23 04:14 EDT by Lewi
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lewi 2004-05-23 04:14:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; ICHTUS; Linux i686; en-US; rv:1.6)
Gecko/20040225 Mozilla Firefox/0.8

Description of problem:
I recompile kernel from redhat and adding some version to 
Makefile file,
so the kernel version will contain two dash

system-config-network fail to parse this

Version-Release number of selected component (if applicable):
system-config-network-1.3.16-1

How reproducible:
Always

Steps to Reproduce:
1.add some version with '-' in kernel makefile
2.running system-config-network
3.don't want running
    

Actual Results:  error message

Expected Results:  runnnin well

Additional info:

Component: system-config-network
Version: 1.3.16
Summary: TBf3ca2c97 NC_functions.py:54:kernel_version:ValueError:
unpack list of wrong size
Traceback (most recent call last):
  File "/usr/sbin/system-config-network-gui", line 183, in ?
    from netconfpkg import NC_functions
  File
"/usr/src/build/377922-noarch/install/usr/share/system-config-network/netconfpkg/__init__.py",
line 61, in ?
  File "<string>", line 1, in ?
  File
"/usr/src/build/377922-noarch/install/usr/share/system-config-network/netconfpkg/Control.py",
line 28, in ?
  File "/usr/share/system-config-network/netconfpkg/NC_functions.py",
line 78, in ?
    if cmp_kernel_version([2,5,0], kernel_version()) < 0:
  File "/usr/share/system-config-network/netconfpkg/NC_functions.py",
line 54, in kernel_version
    (ver, rel) = release.split("-")
ValueError: unpack list of wrong size
 
Local variables in innermost frame:
release: 2.6.5-1.358-ichtus
machine: i686
version: #1 Sat May 22 23:57:02 WIT 2004
nodename: ichtusmobile.org
sysname: Linux
Comment 1 Harald Hoyer 2004-05-24 06:33:01 EDT

*** This bug has been marked as a duplicate of 122223 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:36 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.