Bug 124054 - Existing home directory missing in passwd file
Summary: Existing home directory missing in passwd file
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-users   
(Show other bugs)
Version: 2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-23 14:43 UTC by Joachim Frieben
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-26 03:49:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joachim Frieben 2004-05-23 14:43:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031021

Description of problem:
When creating user foo, the default home directory name /home/foo is
displayed, and it gets created unless the default checkmark is
removed. However, if one wants to reuse some existing home directory
/home/foo, it seems straightforward to remove the checkmark because
you do not want to recreate it together with dotfiles, etc. The home
directory name /home/foo is still displayed in the corresponding box,
and one expects it to be associated with the new user.
However, it turns out that the home directory entry in /etc/passwd
remains empty in this case which is surely wrong and prevents user foo
from logging in.

Version-Release number of selected component (if applicable):
1.2.13-1

How reproducible:
Always

Steps to Reproduce:
1. Create user foo via system-config-users.
2. Remove checkmark for creation of /home/foo.
3. Accept changes.
    

Actual Results:  Error message from GDM when trying to log in because
of non-existing home directory.

Expected Results:  User foo should be able to log in.

Additional info:

Adding /home/foo manually in /etc/passwd makes everything work correctly.

Comment 1 Brent Fox 2004-05-26 03:49:02 UTC
You should leave the "Create home directory" button checked.  I
believe that libuser is smart enough not to write over existing dot
files.  Please file a bug against libuser if you observe dot files
getting overwritten.  Otherwise, I don't think that the current
behavior is a bug.  Unchecking the "Create home directory" button
means that you do not want a home directory for that user.

Comment 2 Joachim Frieben 2004-05-31 19:57:01 UTC
I respectfully disagree. If I do not want *any* home directory 
associated with a newly created user, then I *remove* the /home/foo 
entry in the system-config-users panel (and the checkmark, too). 
There is an obvious difference between *creating* and *assigning* a 
home directory. Removing the checkmark but entering some value for 
the home directory corresponds to the latter case, leaving the 
checkmark as well to the former. This appears pretty logical to me. 
In the case of assigning a home directory no directories/files should 
be created but-of course-the passwd file should be modified 
accordingly.


Note You need to log in before you can comment on or make changes to this bug.