Bug 1240616 - Unable to pause georep session if one of the nodes in cluster is not part of master volume.
Summary: Unable to pause georep session if one of the nodes in cluster is not part of ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On: 1240196 1240229
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-07 11:31 UTC by Kotresh HR
Modified: 2015-07-30 09:49 UTC (History)
8 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1240229
Environment:
Last Closed: 2015-07-30 09:49:29 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kotresh HR 2015-07-07 11:31:14 UTC
+++ This bug was initially created as a clone of Bug #1240229 +++

+++ This bug was initially created as a clone of Bug #1240196 +++

Description of problem:
Unable to pause georep session if one of the nodes in cluster is not part of master volume.

Version-Release number of selected component (if applicable):
mainline

How reproducible:
Always

Steps to Reproduce:
1. Add 3 nodes in the cluster.
2. Create a master volume with 2 nodes.
3. Create a geo rep session.
4. Try to Pause the geo rep session.

Actual results:
Unable to pause georep session

Expected results:
georep session should be paused successfully

Additional info:

[2015-07-06 05:31:23.751865] E [glusterd-op-sm.c:254:glusterd_get_txn_opinfo] (--> 0-management: Unable to get transaction opinfo for transaction ID : d6d23c5d-efe1-4c48-b7b1-6a43e9f6a622
[2015-07-06 05:31:25.066529] I [MSGID: 106327] [glusterd-geo-rep.c:2180:glusterd_get_statefile_name] 0-management: Using passed config template(/var/lib/glusterd/geo-replication/vol1_10.70.46.129_vol1_slave1/gsyncd.conf).
[2015-07-06 05:31:25.408344] E [MSGID: 106308] [glusterd-geo-rep.c:1840:glusterd_op_verify_gsync_running] 0-management: geo-replication session b/w vol1 & 10.70.46.129::vol1_slave1 is not running on this node.
[2015-07-06 05:31:25.408464] E [MSGID: 106301] [glusterd-op-sm.c:5088:glusterd_op_ac_stage_op] 0-management: Stage failed on operation 'Volume Geo-replication', Status : -1

Comment 1 Anand Avati 2015-07-07 11:42:30 UTC
REVIEW: http://review.gluster.org/11564 (glusterd/geo-rep: Fix failure of geo-rep pause) posted (#1) for review on release-3.7 by Kotresh HR (khiremat@redhat.com)

Comment 2 Anand Avati 2015-07-11 02:29:18 UTC
COMMIT: http://review.gluster.org/11564 committed in release-3.7 by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit b99dc077873afe90411085006739d1c1832f083b
Author: Kotresh HR <khiremat@redhat.com>
Date:   Mon Jul 6 15:05:43 2015 +0530

    glusterd/geo-rep: Fix failure of geo-rep pause
    
    Geo-replication pause fails if one or more of the nodes
    in the master cluster is not part of master volume.
    If the master volume bricks are not part of the node,
    it should be ignored. The check is added to fix the issue.
    
    BUG: 1240616
    Change-Id: If10da6921d0c87d6e1c1c4ceba975c4b1e3bf302
    Reviewed-on: http://review.gluster.org/11549
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/11564
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Milind Changire <mchangir@redhat.com>
    Reviewed-by: Saravanakumar Arumugam <sarumuga@redhat.com>

Comment 3 Kaushal 2015-07-30 09:49:29 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.