Bug 1240876 - verify_db.pl doesn't verify DB specified by -a option.
Summary: verify_db.pl doesn't verify DB specified by -a option.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base
Version: 7.0
Hardware: All
OS: All
medium
medium
Target Milestone: pre-dev-freeze
: ---
Assignee: Noriko Hosoi
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-08 01:27 UTC by Hiroko Miura
Modified: 2020-09-13 21:27 UTC (History)
6 users (show)

Fixed In Version: 389-ds-base-1.3.4.0-9.el7
Doc Type: Bug Fix
Doc Text:
The verify-db.pl utility ignored the "-a" option which specifies the path to the database directory and instead used the path defined in the Directory Server configuration. The utility now respects "-a" as expected.
Clone Of:
Environment:
Last Closed: 2015-11-19 11:42:56 UTC
Target Upstream Version:


Attachments (Terms of Use)
operation log (52.98 KB, text/plain)
2015-07-08 01:27 UTC, Hiroko Miura
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github 389ds 389-ds-base issues 1546 0 None None None 2020-09-13 21:27:27 UTC
Red Hat Product Errata RHBA-2015:2351 0 normal SHIPPED_LIVE 389-ds-base bug fix and enhancement update 2015-11-19 10:28:44 UTC

Description Hiroko Miura 2015-07-08 01:27:43 UTC
Created attachment 1049668 [details]
operation log

Description of problem:

verify-db.pl has option '-a' which can specify path to DB.

​https://access.redhat.com/documentation/en-US/Red_Hat_Directory_Server/9.0/html/Configuration_Command_and_File_Reference/Perl_Scripts.html#verify-db.pl

But if verify-db.pl run with -a option, it does not verify DB files under DB directory which is specified by option '-a', but it alreays verify instance DB instead.

Version-Release number of selected component (if applicable):

389-ds-base-1.2.11.15-50


How reproducible:

take DB backup and then run verify-db.pl with -a option.

Steps to Reproduce:
1.take backup by db2bak 
2.run DB verify against backup DB with -a option 

 e.g.
./verify-db.pl -a /var/lib/dirsrv/slapd-test/bak/test-2015_07_06_16_32_07

Actual results:

 DB files under instance's DB directory always get verified. 

Expected results:

DB files under DB directory specified -a option is verified.

Additional info:

N/A

Comment 2 mreynolds 2015-08-06 15:33:12 UTC
Fixed upstream

Comment 4 Simon Pichugin 2015-08-21 12:21:34 UTC
Tested build: 389-ds-base-1.3.4.0-13.el7.x86_64

1.take backup by db2bak 
[root@cloud-qe-12 ~]# db2bak.pl -v -D "cn=directory manager" -w Secret123
Back up directory: /var/lib/dirsrv/slapd-cloud-qe-12/bak/cloud-qe-12-2015_8_21_8_17_47
ldap_initialize( ldap://cloud-qe-12.idmqe.lab.eng.bos.redhat.com:389 )
Successfully added task entry "cn=backup_2015_8_21_8_17_47, cn=backup, cn=tasks, cn=config"

2.run DB verify against backup DB with -a option
[root@cloud-qe-12 bak]# verify-db.pl -a /var/lib/dirsrv/slapd-cloud-qe-12/bak/cloud-qe-12-2015_8_21_8_17_47
*****************************************************************
verify-db: This tool should only be run if recovery start fails
and the server is down.  If you run this tool while the server is
running, you may get false reports of corrupted files or other
false errors.
*****************************************************************
Verify log files in /var/lib/dirsrv/slapd-cloud-qe-12/bak/cloud-qe-12-2015_8_21_8_17_47 ... Good
Verify db files ... Good

Marking as VERIFIED.

Comment 5 errata-xmlrpc 2015-11-19 11:42:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2351.html


Note You need to log in before you can comment on or make changes to this bug.