Bug 1240880 - Something (Epiphany, WebKitGtk4, Pulseaudio, GStreamer, [...]) permits webpages to set the main system volume (audio, sound) to 100%.
Summary: Something (Epiphany, WebKitGtk4, Pulseaudio, GStreamer, [...]) permits webpag...
Keywords:
Status: CLOSED DUPLICATE of bug 1265267
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 22
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-08 02:49 UTC by Diogo Campos
Modified: 2016-01-18 21:54 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-18 21:54:45 UTC


Attachments (Terms of Use)
Screencast of the bug. (1.31 MB, application/octet-stream)
2015-07-08 03:47 UTC, Diogo Campos
no flags Details


Links
System ID Priority Status Summary Last Updated
WebKit Project 140358 None None None Never

Description Diogo Campos 2015-07-08 02:49:27 UTC
- First of all: I understand that this is a known (closed) bug in every upstream mentioned, but, please, see more below. And I also understand that GNOME Web/Epiphany maybe is not the ideal target for a patch; if it's not, please, just change to a more appropriate component.

- BUT, the point is: this is a really, really, really, really bad experience, and, since none of the upstreams want/can fix it, it's probably a good candidate for a downstream patch, I'm right?

# Description of problem:

Some(1) webpages, when playing some(2) audio (or video/audio), can disrespect user choosen max main volume e set it to 100%(3).

1- Or all webpages?
2- Or just HTML 5 audio (video/audio)?
3- Sometimes happens with smaller values. Not sure what "holds" the limit, though.

# Version-Release number of selected component (if applicable):

epiphany-3.16.2-2.fc22.x86_64
webkitgtk4-2.8.3-2.fc22.x86_64
pulseaudio-6.0-4.fc22.x86_64
gstreamer1-1.4.5-1.fc22.x86_64

# Steps to Reproduce:
1. Set main volume (in GNOME Shell) to something less than 100%.
2. Open GNOME Web.
3. Go to https://www.youtube.com/
4. Click on any video and notice the volume instantly raising.

# Expected results:

GNOME Web honor user setted max global volume.

# Actual results:

GNOME Web going insane and giving free hearing damage and heart attacks to everyone :P

Although I'm kidding (and I'm not a doctor), I would insist that (besides a horrible user experience) these two extreme and unlikely situations can still happen if leaded by powerful headphones, or a bad heart condition, or both; I'm wrong?

Comment 1 Diogo Campos 2015-07-08 03:47:12 UTC
Created attachment 1049679 [details]
Screencast of the bug.

Comment 2 Michael Catanzaro 2015-07-08 14:18:02 UTC
The problem is that YouTube has full control of your system volume with JavaScript and if it chooses to set it all the way up, there's nothing we can do about it without new API in PulseAudio to let us have an application volume separate from the system volume. The good news is that I think the PulseAudio folks are going to provide that API. The bad news is, I have no clue what the status of that is, and in the meantime there is nothing we can do.

Once that API becomes available, then it will be possible to fix this in WebKit. We have an upstream bug for this: https://bugs.webkit.org/show_bug.cgi?id=140358

Until then, the only solution is to disable flat volumes: https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Per-application_volumes_change_when_the_Master_volume_is_adjusted

Comment 3 Diogo Campos 2015-07-08 15:39:11 UTC
Ok, sorry for the extra downstream "noise" :/
And thank you for your time and patience, Michael.

I will try the flat thing, meanwhile, to see if I can give Web a bit more of usage, anyway.

Comment 4 Michael Catanzaro 2016-01-18 21:54:45 UTC

*** This bug has been marked as a duplicate of bug 1265267 ***


Note You need to log in before you can comment on or make changes to this bug.