Bug 12410 - Authentication failure w/pam using samba
Authentication failure w/pam using samba
Status: CLOSED DUPLICATE of bug 10666
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-18 01:06 EDT by Henri Schlereth
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-18 01:06:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henri Schlereth 2000-06-18 01:06:17 EDT
Note: This is not a show stopper it puts in a delay and then passes
the user thru. In the Samba archives it is shown as a "ghost failure",
with no solution provided. It may be related to case mangling of the
password, where a failure is logged on each combination of trying to
convert the password.
At a higher level, the number of machines access the server can multiply
the delay factory and in a production environment cause problems.


 version:
 Version to 2.0.7

 From syslog:

 Apr  8 13:27:18 kesrith PAM_pwdb[32520]: authentication failure; (uid=0) 
->
 henris for samba service
 Apr  8 13:27:21 kesrith last message repeated 3 times
 Apr  8 13:27:26 kesrith PAM_pwdb[32521]: authentication failure; (uid=0) 
->
 henris for samba service

 from log.smb
 [2000/04/08 13:27:20, 1] smbd/reply.c:reply_sesssetup_and_X(909)
   Rejecting user 'henris': authentication failed
 [2000/04/08 13:27:22, 1] smbd/reply.c:reply_sesssetup_and_X(909)
   Rejecting user 'henris': authentication failed

 from /etc/pam.d/samba
 auth    required        /lib/security/pam_pwdb.so nullok shadow audit
 account required        /lib/security/pam_pwdb.so

 note: I added the audit.

 I have four Linux/Samba boxes that perform the same error. The all users
 except one(for testing) have matching acounts/passwords on both servers/
 clients (clients are both W95a).I dont use encryption on Windows,I dont
 use smbpasswd or usermap on samba. I have seen this error in the
 following:

 RPM's from Redhat and Samba
 compiled from source from samba and RH (2.0.6)

 samba-2.0.7Pre2 (compiled w/ -lpam)
 samba-TNG-0.11 (compiled w/ -lpam)

 As I said in the begining that it doesnt halt the connection it merely
 induces a brief delay, coughs up the error message. In a production
 environment the delay may well be worse or unacceptable. If required I
 will add my smb.confs from all machines.

Disabling pam authentication makes this go away, but then why have pam
anyway.

This is a duplicate of bug #10666 which is against RHL 6.2
Comment 1 Bill Nottingham 2000-07-19 11:38:36 EDT

*** This bug has been marked as a duplicate of 10666 ***

Note You need to log in before you can comment on or make changes to this bug.