Bug 1241054 - Data Tiering: Rename of file is not heating up the file
Summary: Data Tiering: Rename of file is not heating up the file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Joseph Elwin Fernandes
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: 1242536 1260923
TreeView+ depends on / blocked
 
Reported: 2015-07-08 11:11 UTC by Joseph Elwin Fernandes
Modified: 2016-06-20 00:01 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1242536 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:21:35 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Joseph Elwin Fernandes 2015-07-08 11:11:37 UTC
nchilaka 2015-07-01 07:33:53 EDT

Description of problem:
=========================
When you rename a cold file, the file should get heated up and eventually move to hot tier. But that is not happening.
This is a case of metadata change which means ideally it should increase the counter of file to get heated up, but is not happening

Version-Release number of selected component (if applicable):
============================================================
[root@tettnang ~]# gluster --version
glusterfs 3.7.1 built on Jun 28 2015 11:01:14
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU General Public License.
[root@tettnang ~]# rpm -qa|grep gluster
glusterfs-cli-3.7.1-6.el7rhgs.x86_64
glusterfs-client-xlators-3.7.1-6.el7rhgs.x86_64
glusterfs-fuse-3.7.1-6.el7rhgs.x86_64
glusterfs-geo-replication-3.7.1-6.el7rhgs.x86_64
glusterfs-libs-3.7.1-6.el7rhgs.x86_64
glusterfs-api-3.7.1-6.el7rhgs.x86_64
glusterfs-rdma-3.7.1-6.el7rhgs.x86_64
glusterfs-3.7.1-6.el7rhgs.x86_64
glusterfs-debuginfo-3.7.1-6.el7rhgs.x86_64
glusterfs-server-3.7.1-6.el7rhgs.x86_64
[root@tettnang ~]# 




Steps to Reproduce:
===================
1.create a regular volume and start it.
2.set following options
 performance.quick-read: off
performance.io-cache: off

3.Now attach a tier and enable features.ctr-enabled.
4. fuse mount the volume
5. Create a file and check if it is created in hot tier(works as expected)
6.  Now wait for say about 3min by keeping the setup idle.
7. Now the file should have been moved to cold tier(works as expected)
8.Now do a rename of the file

Actual results:
===============
rename passes, but the file doesnt get heated,even though the ctime changes, which is a metadata change action

Note:
I haven't set promote/demote freq. Which means the default time should be about 120sec
Also, I haven't turned on  features.record-counters or read/write threshold counters, which means I file should get heated if modified even once.


Logs will be attached



Expected results:


Additional info:

Comment 1 Anand Avati 2015-07-08 15:57:53 UTC
REVIEW: http://review.gluster.org/11584 (libgfdb/ctr: Fixing rename or update of link) posted (#1) for review on master by Joseph Fernandes

Comment 2 Joseph Elwin Fernandes 2015-07-08 16:51:45 UTC
Tested by abusing rename :) 

for i in {1..100000}; do mv file file1 ; mv file1 file;  done

Comment 3 Anand Avati 2015-07-09 19:11:34 UTC
COMMIT: http://review.gluster.org/11584 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 3c25f33162c981d18bf78d1fc3536496670959e9
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Wed Jul 8 21:22:53 2015 +0530

    libgfdb/ctr: Fixing rename or update of link
    
    Fixing rename or updating of link in
    1) libgfdb : handling return from updatelink
    2) ctr xlator: correcting freeing of oldbase name in
                   hardlink list in the update link
    
    Change-Id: I1789c492b81876123cd456051a9ae495e876ad46
    BUG: 1241054
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    Reviewed-on: http://review.gluster.org/11584
    Tested-by: Joseph Fernandes
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 4 Nagaprasad Sathyanarayana 2015-10-25 14:56:51 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 5 Niels de Vos 2016-06-16 13:21:35 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.