Bug 1241153 - quota: marker accounting can get miscalculated after upgrade to 3.7
Summary: quota: marker accounting can get miscalculated after upgrade to 3.7
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vijaikumar Mallikarjuna
QA Contact:
URL:
Whiteboard:
Depends On: 1241150
Blocks: 1241831
TreeView+ depends on / blocked
 
Reported: 2015-07-08 15:12 UTC by Vijaikumar Mallikarjuna
Modified: 2016-06-16 13:22 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1241150
: 1241831 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:22:21 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-07-08 15:13:01 UTC
REVIEW: http://review.gluster.org/11583 (quota/marker: accounting goes wrong after upgrade to 3.7) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Anand Avati 2015-07-08 16:57:00 UTC
REVIEW: http://review.gluster.org/11583 (quota/marker: fix spurious failure afr-quota-xattr-mdata-heal.t) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 3 Anand Avati 2015-07-10 07:01:28 UTC
REVIEW: http://review.gluster.org/11583 (quota/marker: fix spurious failure afr-quota-xattr-mdata-heal.t) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 4 Anand Avati 2015-07-10 07:07:35 UTC
REVIEW: http://review.gluster.org/11583 (quota/marker: fix spurious failure afr-quota-xattr-mdata-heal.t) posted (#5) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 5 Vijaikumar Mallikarjuna 2015-07-10 07:08:41 UTC
During quota-update process if inode info is present in size-xattr and
missing in contri-xattrs, then in function '_mq_get_metadata', we set
contri-size as zero (on error -2, which means usage info present, but inode info missing).
With this we are calculating wrong delta and updating the same.

Comment 6 Anand Avati 2015-07-10 08:20:52 UTC
COMMIT: http://review.gluster.org/11583 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit c2cd3aeb0d88117f0929a733e9b05aa3e4d392ac
Author: vmallika <vmallika@redhat.com>
Date:   Wed Jul 8 22:22:50 2015 +0530

    quota/marker: fix spurious failure afr-quota-xattr-mdata-heal.t
    
    During quota-update process if inode info is present in size-xattr and
    missing in contri-xattrs, then in function '_mq_get_metadata', we set
    contri-size as zero (on error -2, which means usage info present, but inode info missing).
    With this we are calculating wrong delta and updating the same.
    
    With this patch we are ignoring errors if inode info in xattrs are missing
    
    Change-Id: I7940a0e299b8bb425b5b43746b1f13f775c7fb92
    BUG: 1241153
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/11583
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Raghavendra G <rgowdapp@redhat.com>

Comment 7 Nagaprasad Sathyanarayana 2015-10-25 14:53:38 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 8 Niels de Vos 2016-06-16 13:22:21 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.