Bug 1241214 - several libraries (p.e. libjawt.so) missing on ppc64le
Summary: several libraries (p.e. libjawt.so) missing on ppc64le
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.8.0-openjdk
Version: 23
Hardware: ppc64le
OS: Linux
high
high
Target Milestone: ---
Assignee: Andrew John Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PPCTracker F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2015-07-08 18:05 UTC by Karsten Hopp
Modified: 2016-02-15 18:01 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-02-15 18:01:18 UTC


Attachments (Terms of Use)

Description Karsten Hopp 2015-07-08 18:05:19 UTC
Description of problem:
java-1.8.0-openjdk-1.8.0.60-7.b16.fc23.ppc64le is missing some files:
libawt_xawt.so
libjawt.so
libjsoundalsa.so
libsplashscreen.so

This causes libreoffice builds to fail:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=2627907


Compare the filelists here:
http://ppc.koji.fedoraproject.org/koji/rpminfo?rpmID=2330522
http://ppc.koji.fedoraproject.org/koji/rpminfo?rpmID=2330530

From the logs it looks like those files got built, but were installed in
/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.60-7.b16.fc23.ppc64/jre/lib/ppc64/
instead of /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.60-7.b16.fc23.ppc64le/jre/lib/ppc64le/

Version-Release number of selected component (if applicable):
java-1.8.0-openjdk-1.8.0.60-7.b16.fc23.

How reproducible:
Always

Comment 1 Andrew John Hughes 2015-07-08 20:10:55 UTC
Upstream OpenJDK, on integrating the ppc64 port, decided to use the same name for both big-endian and little-endian ppc64, because it made their makefiles simpler. However, it breaks various Java tools as you can see.

We've already fixed this in RHEL so that the JDK uses jre/lib/ppc64le on ppc64le, and are in the process of getting it changed in upstream OpenJDK too. The process is slowed down by the need to test the ppc64le build of OpenJDK 9.

The necessary OpenJDK patches are:

http://icedtea.classpath.org/hg/icedtea8-forest/rev/0503e9c58a13
http://icedtea.classpath.org/hg/icedtea8-forest/hotspot/rev/746efa1d4492
http://icedtea.classpath.org/hg/icedtea8-forest/jdk/rev/ea26a8f4db7e

Comment 2 Andrew John Hughes 2016-01-30 07:47:17 UTC
This has been fixed in RHEL for some time. Has it not made it to Fedora yet?

Comment 3 Andrew John Hughes 2016-02-15 18:01:18 UTC
I see:

# S8073139, RH1191652; fix name of ppc64le architecture                                                                                                              
Patch601: %{name}-rh1191652-root.patch
Patch602: %{name}-rh1191652-jdk.patch
Patch603: %{name}-rh1191652-hotspot-aarch64.patch

in the Fedora spec file, and no further response to my last comment, so I'm closing this as fixed.


Note You need to log in before you can comment on or make changes to this bug.