Bug 1241231 - director HA deployment fails when duplicate service tenant is created
Summary: director HA deployment fails when duplicate service tenant is created
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: Director
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: Director
Assignee: Jay Dobies
QA Contact: Leonid Natapov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-08 19:17 UTC by wes hayutin
Modified: 2015-08-05 13:58 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-heat-templates-0.8.6-33.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, uncoordinated creation of the overcloud Keystone admin tenant caused errors in a deployment with more than one controller. As a consequence, Heat stack creation failed on the ControllerNodesPostDeployment resource, and Keystone returned a 409 ERROR: openstack Conflict occurred attempting to store project - Duplicate Entry (HTTP 409). The Puppet run failed at that point. The fix for this problem includes the creation of the admin tenant on the pacemaker master node first. As a result, deployments with more than one controller correctly create the overcloud keystone admin user. After a successful deployment you can verify this by interacting with any of the overcloud services as the admin user: # on the undercloud system, for example: $ source overcloudrc $ keystone user-list
Clone Of:
Environment:
Last Closed: 2015-08-05 13:58:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description wes hayutin 2015-07-08 19:17:14 UTC
Description of problem:

  ERROR: openstack Conflict occurred attempting to store project - Duplicate Entry (HTTP 409) (Request-ID: req-348f0101-0800-4c69-9a7c-76356d454429)\u001b[0m\n\u001b[1;31mError: /Stage[main]/Keystone::Roles::Admin/Keystone_tenant[services]/ensure: change from absent to present failed: Execution of '/usr/bin/openstack project create --format shell services --enable --description Tenant for the openstack services' returned 1: ERROR: openstack Conflict occurred attempting to store project - Duplicate Entry (HTTP 409) (Request-ID: req-348f0101-0800-4c69-9a7c-76356d454429)\u001b[0m\n\u001b[1;31mWarning: /Stage[main]/Heat::Keystone::Domain/Exec[heat_domain_create]: Skipping because of failed dependencies\u001b[0m\n\u001b[1;31mWarning: /Stage[main]/Heat::Keystone::Domain/Heat_domain_id_setter[heat_domain_id]: Skipping because of failed dependencies\u001b[0m\n", 
01:36:28.179     "deploy_status_code": 6

Comment 6 John Trowbridge 2015-07-08 19:30:58 UTC
I think this is actually happening during deploy rather than post config. It is definitely happening in heat/puppet. I am not sure if it is a T-H-T or OPM bug though.

Comment 7 Mike Burns 2015-07-10 03:28:54 UTC
This is fixed with the newew version of this patch[1] for bug 1235748

[1] https://review.openstack.org/#/c/180566/

Comment 9 Leonid Natapov 2015-07-21 08:05:52 UTC
wasn't able to reproduce the issue. deployment passes.

openstack-tripleo-heat-templates-0.8.6-44.el7ost.noarch

Comment 11 errata-xmlrpc 2015-08-05 13:58:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.