Bug 1241331 - Machine type reported by guest is different with that in RHEL.7.1 GA version
Summary: Machine type reported by guest is different with that in RHEL.7.1 GA version
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: x86_64
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Miroslav Rezanina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-09 03:22 UTC by xiagao
Modified: 2015-12-04 16:48 UTC (History)
13 users (show)

Fixed In Version: qemu-kvm-rhev-2.3.0-11.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-04 16:48:51 UTC
Target Upstream Version:


Attachments (Terms of Use)
qemu-kvm-rhev-2.3.0-7.el7.x86_64 (344.63 KB, image/png)
2015-07-09 03:23 UTC, xiagao
no flags Details
guest report in qemu-img-rhev-2.1.2-23.el7.x86_64 (327.77 KB, image/png)
2015-07-09 03:25 UTC, xiagao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Description xiagao 2015-07-09 03:22:50 UTC
Description of problem:
Check machine type in guest os, the result is different with RHEL7.1 GA.


Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.3.0-7.el7.x86_64
kernel-3.10.0-289.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.boot up a Win8 guest.
/usr/libexec/qemu-kvm \
    -S  \
    -name 'virt-tests-vm1'  \
    -sandbox off  \
    -machine pc  \
    -nodefaults  \
    -vga qxl  \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20150706-111855-IzHMPU30,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control  \
    -chardev socket,id=qmp_id_catch_monitor,path=/tmp/monitor-catch_monitor-20150706-111855-IzHMPU30,server,nowait \
    -mon chardev=qmp_id_catch_monitor,mode=control  \
    -chardev socket,id=serial_id_serial0,path=/tmp/serial-serial0-20150706-111855-IzHMPU30,server,nowait \
    -device isa-serial,chardev=serial_id_serial0  \
    -chardev socket,id=seabioslog_id_20150706-111855-IzHMPU30,path=/tmp/seabios-20150706-111855-IzHMPU30,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20150706-111855-IzHMPU30,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=03 \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,bus=pci.0,addr=04 \
    -drive id=drive_image1,if=none,cache=none,snapshot=off,aio=native,format=qcow2,file=/home/my_auto/autotest-devel/client/tests/virt/shared/data/images/win8-64.1-virtio-scsi.qcow2 \
    -device scsi-hd,id=image1,drive=drive_image1,serial=y\;M\(2eBt\+QXv\&\. \
    -device virtio-net-pci,mac=9a:f8:f9:fa:fb:fc,id=id50s9BZ,vectors=4,netdev=idSWy0Ie,bus=pci.0,addr=05  \
    -netdev tap,id=idSWy0Ie,vhost=on  \
    -m 32768  \
    -smp 16,maxcpus=16,cores=8,threads=1,sockets=2  \
    -cpu 'SandyBridge',+sep,+kvm_pv_unhalt,hv_spinlocks=0x1fff,hv_vapic,hv_time \
    -drive id=drive_cd1,if=none,snapshot=off,aio=native,media=cdrom,file=/home/my_auto/autotest-devel/client/tests/virt/shared/data/isos/windows/winutils.iso \
    -device scsi-cd,id=cd1,drive=drive_cd1,serial=y\;M\(2eBt\+QXv\&\. \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -spice vnc:0  \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off,strict=off \
    -enable-kvm \
    -monitor stdio
2.Check machine type in guest.
#wmic csproduct get Version

3.Downgrade qemu-kvm version to RHEL.7.1 GA version
qemu-img-rhev-2.1.2-23.el7.x86_64

4.Boot up guest with the same CLI.

5.Check machine type in guest.
#wmic csproduct get Version

Actual results:
after step2.
Version
pc-i440fx-rhel7.0.0

after step 5.
Version
RHEL 7.0.0 PC (i440FX + PIIX, 1996)

Expected results:

after step2 ,the result should be:
Version
RHEL 7.0.0 PC (i440FX + PIIX, 1996)

Additional info:

Comment 1 xiagao 2015-07-09 03:23:47 UTC
Created attachment 1050092 [details]
qemu-kvm-rhev-2.3.0-7.el7.x86_64

Comment 2 xiagao 2015-07-09 03:25:05 UTC
Created attachment 1050093 [details]
guest report in qemu-img-rhev-2.1.2-23.el7.x86_64

Comment 4 Miroslav Rezanina 2015-07-09 10:59:35 UTC
There's no change in machine type setup. However, description value is used for 2.1.2 version, name value is used fo 2.3.0 version.

Comment 5 xiagao 2015-07-10 09:04:31 UTC
sorry, update qemu CLI:

     -machine pc-i440fx-rhel7.0.0 

instead of: 

     -machine pc

Comment 6 Miroslav Rezanina 2015-07-17 08:57:48 UTC
Fix included in qemu-kvm-rhev-2.3.0-11.el7

Comment 8 huiqingding 2015-07-21 03:37:47 UTC
Reproduce this bug using the following version:
qemu-kvm-rhev-2.3.0-10.el7.x86_64
kernel-3.10.0-292.el7.x86_64

Steps to Reproduce:
1.boot up a Win8 guest.
/usr/libexec/qemu-kvm \
    -S  \
    -name 'virt-tests-vm1'  \
    -sandbox off  \
    -machine pc-i440fx-rhel7.0.0   \
    -nodefaults  \
    -vga qxl  \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20150706-111855-IzHMPU30,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control  \
    -chardev socket,id=qmp_id_catch_monitor,path=/tmp/monitor-catch_monitor-20150706-111855-IzHMPU30,server,nowait \
    -mon chardev=qmp_id_catch_monitor,mode=control  \
    -chardev socket,id=serial_id_serial0,path=/tmp/serial-serial0-20150706-111855-IzHMPU30,server,nowait \
    -device isa-serial,chardev=serial_id_serial0  \
    -chardev socket,id=seabioslog_id_20150706-111855-IzHMPU30,path=/tmp/seabios-20150706-111855-IzHMPU30,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20150706-111855-IzHMPU30,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=03 \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,bus=pci.0,addr=04 \
    -drive id=drive_image1,if=none,cache=none,snapshot=off,aio=native,format=qcow2,file=/home/win8-64.1-virtio-scsi.qcow2 \
    -device scsi-hd,id=image1,drive=drive_image1,serial=y\;M\(2eBt\+QXv\&\. \
    -device virtio-net-pci,mac=9a:f8:f9:fa:fb:fc,id=id50s9BZ,vectors=4,netdev=idSWy0Ie,bus=pci.0,addr=05  \
    -netdev tap,id=idSWy0Ie,vhost=on  \
    -m 4096  \
    -smp 16,maxcpus=16,cores=8,threads=1,sockets=2  \
    -cpu 'SandyBridge',+sep,+kvm_pv_unhalt,hv_spinlocks=0x1fff,hv_vapic,hv_time \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -vnc :0  \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off,strict=off \
    -enable-kvm \
    -monitor stdio

2.Check machine type in guest.
#wmic csproduct get Version

3.Downgrade qemu-kvm version to RHEL.7.1.z version
qemu-kvm-rhev-2.1.2-23.el7_1.4.x86_64

4.Boot up guest with the same CLI.

5.Check machine type in guest.
#wmic csproduct get Version

Actual results:
after step2.
Version
pc-i440fx-rhel7.0.0

after step 5.
Version
RHEL 7.0.0 PC (i440FX + PIIX, 1996)

Comment 9 huiqingding 2015-07-21 03:41:44 UTC
Verify this bug using the following version:
qemu-kvm-rhev-2.3.0-12.el7.x86_64
kernel-3.10.0-292.el7.x86_64

Use the same test steps of comment #8,  after step 2, the output is same as step 5:
Version
RHEL 7.0.0 PC (i440FX + PIIX, 1996)

Comment 10 juzhang 2015-07-27 04:37:44 UTC
According to comment8 and comment9, set this issue as verified.

Comment 12 errata-xmlrpc 2015-12-04 16:48:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.