Bug 1241355 - libvirt output an unknown error when use blockjob check a not exist disk path
Summary: libvirt output an unknown error when use blockjob check a not exist disk path
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.2
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Peter Krempa
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-09 06:13 UTC by Luyao Huang
Modified: 2015-11-19 06:48 UTC (History)
7 users (show)

Fixed In Version: libvirt-1.2.17-2.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 06:48:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2202 0 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2015-11-19 08:17:58 UTC

Description Luyao Huang 2015-07-09 06:13:46 UTC
Description of problem:
libvirt output an unknown error when use blockjob check a not exist disk path

Version-Release number of selected component (if applicable):
libvirt-1.2.17-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.
# virsh domblklist r7
Target     Source
------------------------------------------------
hda        /var/lib/libvirt/images/r7_latest.img
sdb        iqn.2014-11.com.lhuang:tgt1/2

2.
# virsh blockjob r7 1123
error: An error occurred, but the cause is unknown


3.

Actual results:
libvirt output an unknown error when use blockjob check a not exist disk path 

Expected results:
Point out we used a invalid address

Additional info:

A patch already send to review:
http://www.redhat.com/archives/libvir-list/2015-July/msg00370.html

Comment 1 Peter Krempa 2015-07-10 07:27:26 UTC
Upstream fix:
commit b5c2245b0cddbb605fece8d8f3c7075d269e3302
Author: Luyao Huang <lhuang@redhat.com>
Date:   Thu Jul 9 11:49:15 2015 +0800

    qemu: report error for non-existing disk in blockjobinfo
    
    Before:
    
     # virsh blockjob r7 vdc
     error: An error occurred, but the cause is unknown
    
    After:
    
     # virsh blockjob r7 vdc
     error: Disk 'vdc' not found in the domain

v1.2.17-60-gb5c2245

Comment 4 Yang Yang 2015-07-14 02:33:25 UTC
Verified with libvirt-1.2.17-2.el7.x86_64

Steps
1. # virsh domblklist  vm3
Target     Source
------------------------------------------------
vda        gluster-vol1/rhel7.qcow2

2.# virsh blockjob vm3 vda
No current block job for vda

3. # virsh blockjob vm3 vda2
error: invalid argument: disk vda2 not found in the domain

Comment 6 errata-xmlrpc 2015-11-19 06:48:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2202.html


Note You need to log in before you can comment on or make changes to this bug.