Bug 124137 - files downloaded or saved to Desktop take a long time to appear
files downloaded or saved to Desktop take a long time to appear
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-24 09:06 EDT by Bryan Cole
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 08:19:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Cole 2004-05-24 09:06:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020618

Description of problem:
When files are saved to (or downloaded to) the Desktop, the new files
take a very long time to actually appear on the desktop (presumbly
because nautilus has the desktop refresh rate set to some long period).

In Gnome-2.4 it was possible to work around this using the Ctrl-R
keyboard shortcut to force a refresh of the desktop. Now, this
shortcut has been disabled (why?) in 2.6, there doesn't appear to be a
good way to force a desktop refresh except by opening the desktop in a
new nautilus window and doing a refresh there.

Version-Release number of selected component (if applicable):
2.6 (but also a problem in 2.4)

How reproducible:
Always

Steps to Reproduce:
1. Download a file to the desktop
2. Wait for it to appear on the desktop
3. ... and wait
4. .... and wait
5. ..... and wait
    

Actual Results:  desktop refresh takes far too long

Expected Results:  new files in the desktop folder should appear
immediately

Additional info:
Comment 1 Mark Levitt 2004-08-30 02:27:46 EDT
I've seen a similar problem where files saved to ~/Desktop do not
actually appear on the desktop. 

I'm not sure if waiting helps, but if I double-click "username Home"
and double-click "Desktop", the file appears on the desktop. That is,
if I open the Desktop folder manually, the actuall desktop is updated.
Comment 2 Mark Levitt 2004-08-30 02:31:05 EDT
I should add that my home directory is NFS mounted.

Comment 3 Alexander Larsson 2004-08-30 06:25:11 EDT
Do you have a working fam or gamin setup?
That should work with a NFS homedir if you're downloading on the same
machine.
Comment 4 Alexander Larsson 2004-10-05 08:19:02 EDT
Recent nautilus in rawhide fixes the ctrl-r on the desktop to work
again. There was also a bug in gamin that made it not detect changes
to the desktop that has been fixed. I consider this fixed.

Note You need to log in before you can comment on or make changes to this bug.