Bug 1241409 - With RHEL 7.2, sssd-dbus package no longer needed in Satellite 6 repository
Summary: With RHEL 7.2, sssd-dbus package no longer needed in Satellite 6 repository
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Packaging
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Kedar Bidarkar
URL:
Whiteboard:
Depends On: 1180604
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-09 07:42 UTC by Jan Pazdziora
Modified: 2019-04-01 20:26 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1205320
Environment:
Last Closed: 2016-07-27 08:53:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Jan Pazdziora 2015-07-09 07:42:50 UTC
+++ This bug was initially created as a clone of Bug #1205320 +++

Description of problem:

Currently sssd-dbus is the only package which needs to be fetched from the repo

'rhel-7-server-optional-rpms'. jmontleo suggested we get this in to sat6.repo

Let's track this issue here.

Version-Release number of selected component (if applicable):
sat6.1-Beta-snap7-compose3/Satellite-6.1.0-RHEL-7-20150320.1

How reproducible:


Steps to Reproduce:
1. Package is required while running 
2. katello-installer --foreman-ipa-authentication=true
3.

Actual results:
unable to fetch sssd-dbus and requires 'rhel-7-server-optional-rpms' repo to fetch it.

Expected results:
should be part of sat6.repo as per jason's/jmontleo suggestion.

Additional info:

[...]

--- Additional comment from Tazim Kolhar on 2015-05-19 09:48:16 CEST ---

VERIFIED:
# rpm -qa | grep foreman
foreman-1.7.2.21-1.el7sat.noarch
ruby193-rubygem-foreman_discovery-2.0.0.13-1.el7sat.noarch
foreman-libvirt-1.7.2.21-1.el7sat.noarch
ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el7sat.noarch
foreman-postgresql-1.7.2.21-1.el7sat.noarch
ruby193-rubygem-foreman_bootdisk-4.0.2.13-1.el7sat.noarch
dell-pem710-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-ovirt-1.7.2.21-1.el7sat.noarch
rubygem-hammer_cli_foreman-0.1.4.11-1.el7sat.noarch
foreman-selinux-1.7.2.13-1.el7sat.noarch
foreman-gce-1.7.2.21-1.el7sat.noarch
ruby193-rubygem-foreman-redhat_access-0.1.0-1.el7sat.noarch
ruby193-rubygem-foreman-tasks-0.6.12.5-1.el7sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.4-1.el7sat.noarch
rubygem-hammer_cli_foreman_docker-0.0.3.6-1.el7sat.noarch
ruby193-rubygem-foreman_docker-1.2.0.12-1.el7sat.noarch
ruby193-rubygem-foreman_hooks-0.3.7-2.el7sat.noarch
rubygem-hammer_cli_foreman_bootdisk-0.1.2.7-1.el7sat.noarch
foreman-proxy-1.7.2.4-1.el7sat.noarch
dell-pem710-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
dell-pem710-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-2.noarch
foreman-vmware-1.7.2.21-1.el7sat.noarch
rubygem-hammer_cli_foreman_discovery-0.0.1.10-1.el7sat.noarch
foreman-compute-1.7.2.21-1.el7sat.noarch
foreman-debug-1.7.2.21-1.el7sat.noarch


steps:
#  subscription-manager repos --enable rhel-7-server-optional-rpms
Repository 'rhel-7-server-optional-rpms' is enabled for this system.

# yum install -y sssd-dbus
Loaded plugins: product-id, subscription-manager
Installed:
  sssd-dbus.x86_64 0:1.12.2-58.el7_1.6                                          

Dependency Installed:
  c-ares.x86_64 0:1.10.0-3.el7                                                  
  cyrus-sasl-gssapi.x86_64 0:2.1.26-17.el7                                      
  libdhash.x86_64 0:0.4.3-24.el7                                                
  libldb.x86_64 0:1.1.17-2.el7                                                  
  libsss_idmap.x86_64 0:1.12.2-58.el7_1.6                                       
  libsss_nss_idmap.x86_64 0:1.12.2-58.el7_1.6                                   
  libtdb.x86_64 0:1.3.0-1.el7                                                   
  sssd-client.x86_64 0:1.12.2-58.el7_1.6                                        
  sssd-common.x86_64 0:1.12.2-58.el7_1.6                                        
  sssd-krb5-common.x86_64 0:1.12.2-58.el7_1.6                                   

Complete!

as per the comment https://bugzilla.redhat.com/show_bug.cgi?id=1205320#c6  sssd-dbus is installed hence the bz is verified

---

In RHEL 7.2, sssd-dbus will be in base RHEL. So for Satellite 6.x releases that will go out after RHEL 7.2 is out, the package no longer should be in Satellite 6.x repo. Hence this bugzilla, to track this change for post 6.1 releases.

Comment 2 Jan Pazdziora 2015-11-23 14:43:25 UTC
With RHEL 7.2 released and bug 1180604 resolved, this is no longer needed because bug 1205320 was not addressed.

It would be nice though for QE to check that katello-installer --foreman-ipa-authentication=true now passes without the Optional channel.

Comment 3 Bryan Kearney 2015-12-18 17:20:55 UTC
Moving this to ON_QA per comment 2 for verification

Comment 4 Corey Welton 2016-03-18 21:16:10 UTC
Testing notes:  

First part of this tested.  Will leave the rest to someone who has a better understanding of IPA. 

[root@rhsm-qe-3 ~]# yum install sssd-dbus

==============================================================================================================================================================
 Package                                Arch                         Version                                   Repository                                Size
==============================================================================================================================================================
Installing:
 sssd-dbus                              x86_64                       1.13.0-40.el7_2.1                         rhel-7-server-rpms                       157 k
Installing for dependencies:
 c-ares                                 x86_64                       1.10.0-3.el7                              rhel-7-server-rpms                        78 k
 libdhash                               x86_64                       0.4.3-25.el7                              rhel-7-server-rpms                        27 k
 libldb                                 x86_64                       1.1.20-1.el7_2.2                          rhel-7-server-rpms                       124 k
 libsss_idmap                           x86_64                       1.13.0-40.el7_2.1                         rhel-7-server-rpms                       102 k
 libsss_nss_idmap                       x86_64                       1.13.0-40.el7_2.1                         rhel-7-server-rpms                       101 k
 libtdb                                 x86_64                       1.3.6-2.el7                               rhel-7-server-rpms                        45 k
 sssd-client                            x86_64                       1.13.0-40.el7_2.1                         rhel-7-server-rpms                       157 k
 sssd-common                            x86_64                       1.13.0-40.el7_2.1                         rhel-7-server-rpms                       1.1 M

Transaction Summary
==============================================================================================================================================================
Install  1 Package (+8 Dependent packages)

Comment 5 Kedar Bidarkar 2016-03-30 21:21:19 UTC
VERIFIED With sat62-snap4

Comment 8 errata-xmlrpc 2016-07-27 08:53:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.