Bug 1241426 - An error appeared in the UI if choose cancel deploy HE
Summary: An error appeared in the UI if choose cancel deploy HE
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 3.5.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Simone Tiraboschi
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On: 1235591
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-09 08:31 UTC by cshao
Modified: 2016-03-09 19:13 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, a value for OVEHOSTED_CORE/nodeSetup was set later in the hosted-engine setup script, which caused an error if the user decided to abort setup at the first question, when the script tried to access OVEHOSTED_CORE/nodeSetup and found nothing. This was fixed by initially setting a default value for OVEHOSTED_CORE/nodeSetup, so the user can abort setup at the first question without errors.
Clone Of:
Environment:
Last Closed: 2016-03-09 19:13:08 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)
ovirt-hosted-engine-setup-20150709070600-82iqjb.log (113.54 KB, text/plain)
2015-07-09 08:31 UTC, cshao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0375 normal SHIPPED_LIVE ovirt-hosted-engine-setup bug fix and enhancement update 2016-03-09 23:48:34 UTC
oVirt gerrit 37600 None None None Never

Description cshao 2015-07-09 08:31:02 UTC
Created attachment 1050171 [details]
ovirt-hosted-engine-setup-20150709070600-82iqjb.log

Description of problem:
An error appeared in the UI if choose cancel deploy HE. The error just flashed on the screen.

ERROR otopi.context context._executeMethod:161 Failed to execute stage 'Clean up': 'OVEHOSTED_CORE/nodeSetup'

Version-Release number of selected component (if applicable):
ovirt-node-3.2.3-11.el6.noarch
ovirt-node-plugin-hosted-engine-0.2.0-16.0.el6ev.noarch
ovirt-hosted-engine-setup-1.2.5.1-1.el6ev.noarch
ovirt-hosted-engine-ha-1.2.6-2.el6ev.noarch
rhev-hypervisor6-6.7-20150707.0.el6ev

How reproducible:
100%

Steps to Reproduce:
1. Install RHEV-H and enabled Network.
2. Enable "PXE Boot Engine VM"
3. Click <Setup Hosted Engine>
4. Are you sure you want to continue? (Yes, No), input NO.
5. check /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-*.log

Actual results:
An error appeared in the UI if choose cancel deploy HE.
The error just flashed on the screen.

Expected results:
No error appeared in the UI if choose cancel deploy HE.

Additional info:

Comment 1 Sandro Bonazzola 2015-07-09 11:49:10 UTC
On hosted engine side:
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line 142, in _executeMethod
  File "/usr/share/ovirt-hosted-engine-setup/plugins/ovirt-hosted-engine-setup/core/answerfile.py", line 128, in _save_answers_at_cleanup
  File "/usr/share/ovirt-hosted-engine-setup/plugins/ovirt-hosted-engine-setup/core/answerfile.py", line 73, in _save_answers
KeyError: 'OVEHOSTED_CORE/nodeSetup'


Please open a separate bug on the node TUI: it should allow you to see what happened if an error is raised and not just flash on the screen.

Comment 2 Simone Tiraboschi 2015-07-20 09:52:58 UTC
Aborting at the first question hosted-engine will not persist the answerfile but at that point it will be almost empty.

Comment 3 Nikolai Sednev 2015-07-29 11:51:34 UTC
Which UI being described in the bug? The WEBUI or TUI?

Comment 4 cshao 2015-07-30 02:43:13 UTC
(In reply to Nikolai Sednev from comment #3)
> Which UI being described in the bug? The WEBUI or TUI?

TUI

Comment 5 Nikolai Sednev 2015-09-07 14:29:02 UTC
Hi Simone,
There is no RHEVH-HE currently available for 3.6.
Please provide me with RHEVH7.2-HE capable image, so this bug could be verified.

Comment 6 Nikolai Sednev 2015-11-15 17:56:37 UTC
Failed to reproduce on Red Hat Enterprise Virtualization Hypervisor (Beta) release 7.2 (20151113.123.el7ev) - works for me.


[ INFO  ] Stage: Initializing
[ INFO  ] Generating a temporary VNC password.
[ INFO  ] Stage: Environment setup
          Continuing will configure this host for serving as hypervisor and create a VM where you have to install oVirt Engine afterwards.
          Are you sure you want to continue? (Yes, No)[Yes]: NO
[WARNING] Aborted
[ INFO  ] Stage: Clean up
[ INFO  ] Generating answer file '/var/lib/ovirt-hosted-engine-setup/answers/answers-20151115175040.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
Something went wrong setting up hosted engine, or the setup process was cancelled.

Press any key to continue...




mom-0.5.1-1.el7ev.noarch
sanlock-3.2.4-1.el7.x86_64
libvirt-1.2.17-13.el7.x86_64
qemu-kvm-rhev-2.3.0-31.el7.x86_64
vdsm-4.17.10.1-0.el7ev.noarch
ovirt-vmconsole-host-1.0.0-1.el7ev.noarch
ovirt-vmconsole-1.0.0-1.el7ev.noarch
ovirt-host-deploy-1.4.1-0.0.master.el7ev.noarch
ovirt-hosted-engine-setup-1.3.0-1.el7ev.noarch
ovirt-hosted-engine-ha-1.3.2.1-1.el7ev.noarch

Comment 8 errata-xmlrpc 2016-03-09 19:13:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0375.html


Note You need to log in before you can comment on or make changes to this bug.