Bug 1241480 - ganesha volume export fails in rhel7.1
Summary: ganesha volume export fails in rhel7.1
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: ganesha-nfs
Version: mainline
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1239057
Blocks: 1202842 1241885
TreeView+ depends on / blocked
 
Reported: 2015-07-09 10:08 UTC by Meghana
Modified: 2016-06-16 13:22 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1239057
: 1241885 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:22:21 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-07-09 10:09:53 UTC
REVIEW: http://review.gluster.org/11594 (NFS-Ganesha : Export fails on RHEL 7.1) posted (#1) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 2 Anand Avati 2015-07-09 10:30:08 UTC
REVIEW: http://review.gluster.org/11594 (NFS-Ganesha : Export fails on RHEL 7.1) posted (#2) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 3 Anand Avati 2015-07-10 07:06:11 UTC
REVIEW: http://review.gluster.org/11594 (NFS-Ganesha : Export fails on RHEL 7.1) posted (#3) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 4 Anand Avati 2015-07-10 07:09:58 UTC
REVIEW: http://review.gluster.org/11594 (NFS-Ganesha : Export fails on RHEL 7.1) posted (#4) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 5 Anand Avati 2015-07-10 10:04:22 UTC
COMMIT: http://review.gluster.org/11594 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 87bce01f323621c106a7fde221ea406abede41fc
Author: Meghana M <mmadhusu@redhat.com>
Date:   Thu Jul 9 03:34:07 2015 +0530

    NFS-Ganesha : Export fails on RHEL 7.1
    
    We grep for CONFFILE parameter in "/etc/syconfig/ganesha"
    file to find out the path of the ganesha config file.
    In RHEL 7.1, this parameter does not exist in the file and
    we can't find out the ganesha config file. Export
    fails invariably due to this. Changing this pattern to
    a more generic one and default it to "/etc/ganesha/ganesha.conf"
    
    Change-Id: I4ac97b1b5ee4f5a7e448a351b7c6270385dffe61
    BUG: 1241480
    Signed-off-by: Meghana M <mmadhusu@redhat.com>
    Reviewed-on: http://review.gluster.org/11594
    Reviewed-by: soumya k <skoduri@redhat.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 7 Nagaprasad Sathyanarayana 2015-10-25 15:18:42 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 8 Niels de Vos 2016-06-16 13:22:21 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.