Bug 12415 - Need to trap/report errors when installing modules (esp. if they require parameters)
Summary: Need to trap/report errors when installing modules (esp. if they require para...
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Erik Troan
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-18 13:24 UTC by Stelian Pop
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-26 19:20:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stelian Pop 2000-06-18 13:24:38 UTC
If I try to insert the NE2000 module (during a NFS install), without
giving extra parameters (needed for my card, because it's an old ISA one),
it doesn't work (as expected) but gives a not so correct error:
	Unable to insert module: (null) <-- not exactly sure, memory copy :)

But in the text console (Alt-F3) I can see an error message of the form:
device not found or something...

Maybe we should warn the users (in the error dialog) that this error
might be caused by not specifying a required parameter to the module?

Stelian.

Comment 1 Michael Fulbright 2000-06-22 19:48:42 UTC
Passed to test lab for verification.

Comment 2 Brock Organ 2000-06-27 18:37:23 UTC
hmmmmmm ... our ne2000 is recognized both with and w/out parameters in test ...
this error may be hardware specific ... 

the request for more informative user error in the dialog will be added to our
feature request list ... thanks for your report!

Comment 3 Stelian Pop 2000-06-28 12:19:05 UTC
My NE2K ISA card is a cheap one (15$). 

When manually doing a modprobe ne (without options on the command line nor the
/etc/conf.modules), the kernel prints out (/var/log/messages):

kernel: ne.c: No PCI cards found. Use "io=0xNNN" value(s) for ISA cards.

I'll try again with the beta2, but for as long as I remember, any ISA NE2K card
I have tried worked only when giving the explicit io parameter...

Stelian.

Comment 4 Erik Troan 2000-11-21 18:18:37 UTC
Catching errors from the kernel log would be very difficult to do, and it's not
clear where to display the messages.


Note You need to log in before you can comment on or make changes to this bug.